Vali's EPG for DreamOS

  • Anbei der aktuelle Kit von Vali's EPG fürs DreamOS, jetzt auch mit FHD Support von zombi und arki und Support für das Instant EPG Timer Plugin sowie das Anpassen der Bouquet Tasten.

  • Na ja es war nicht viel Arbeit - da ist nur ein eTimer drinnen und der RefToString Renderer aus dem Merlin hat gefehlt, den habe ich einfach dazu gepackt, womit man das *.deb evt iim Merlin mit overwrite installieren muss, aber was solls, sie können sich eigene Version für Ihren Feed machen wenn sie wollen.

  • Wenn dir eine zusätzliche Bestätigung wichtig ist, ich hab's auch mal probiert (benutze es aber normalerweise nicht) und es läuft bei mir ebenfalls problemlos.

  • Fixen kann ich das bestimmt nicht :wacko:


    Wenn in Kanalliste -> Menü -> "Verschiemodus aktivert" wird muß anschließen das Kanallisten-Menü so wie auf dem 2. Screenshot aussehen.
    Bei Valis EPG tut es das aber nicht. Sieht genau so aus wie vorher und der Verschiebemodus lässt sich so nicht ordenlich deaktivieren.

  • hallo, habe mich hier neu angemeldet. Bin seit Tagen auf der Suche nach diesem epg. Habe mir die dm900 ultra angeschafft und war diese Übersicht des vali´s epg bei enigma 2.0 gewohnt.

    Super dass es euch gelunden ist es auf die dreamOs anzupassen.

    Vielen Dank an gutemine

  • Na weil du das so schön geschrieben hast ,hab ich mich mal breitschlagen lassen :) ,es gibt zwar auch noch das AdvancedChannelSelection von JD ,was ja eigentlich die Weiterführung dieses Plugins ist ,nur leider hat da JD das ganze noch nicht wirklich ans DreamOS angepasst.

    Daher hab ich mir mal das original vorgenommen und jetzt wäre das Plugin default HD und Fullhd im neuem Design sowie für sämtliche Skinauflösungen Skinbar durch die eingebaute Skincomponente. ;)

    Ich müsste nur noch ein wenig Feinarbeit machen aber dann wäre auch dieses recht alte Plugin dann doch in jeder Skinauflöung nutzbar :):)

  • Da ich den Plugins aber Sachen mit gebe was jetzt noch nicht im e2 ist kann und werde ich das erst posten wenn das e2 das nötige update dafür hat.

    Ich habe bis jetzt fast 40 GIT Plugins ,denke auch alle Systemscreens sowie eine Menge weiterer Plugins schon fertig gemacht ,vieles davon hat Reichi bzw. Dream und wenn sie es für gut befinden und auch so einbauen können wie es sein sollte und zu ihrem Konzept passt wird das alles später mal direkt im e2 sein und dann hat man vieles default halt in HD und Fullhd im e2 ohne da große Verränkungen machen zu müssen.

    Und das ist dann auch noch weiter Ausbaufähig für zukünftige ..... (was auch immer für Auflösungen ) .


  • So sehe ich das auch ,erstmal muss Dream das auch drin haben ,es kann sich ja sogar noch was ändern wenn Dream sagt anderst wäre es noch besser oder Dream sagt es kann so garnicht rein kommen (was ich aber denke nicht hoffe :) ),erst dann macht das alles wirklich Sinn.

    Hier bei mir ist halt schon viel fertig was ich auch gern den Pluginerstellern dann gebe und wenn sie es möchten können sie es übernehmen und wenn nicht dann ist es auch noch so .


    Hier mal die neuen HD screens des Valiepg. ,hab da auch gleich mal die description fürs Hauptmenü mit rein gemacht so das nicht das ID Zeugs da steht .;)



  • Glaub mir ich auch ;) ,ich möchte nicht wissen ob Reichi da nicht manchmal das ganze zu viel ist was ich ihm da immer gebe,ich hab ihm da in den letzten Monaten bombadiert mit den ganzen Sachen ,dann dort oder dort noch was gefunden ,wieder angepasst und ihm wieder gesendet usw. ,das auch nur weil ich es gern so schnell wie möglich im e2 hätte :) .

    Aber wie gesagt es muss auch alles passen und vorallem soll es auch gut funktionieren und da muss Dream halt auch noch Sachen ins e2 einbauen und sie arbeiten ja nicht nur an diesem sondern haben auch noch ganz andere wichtigere Dinge zu erledigen .

    Sollte aber der Fullhd default kommen dann wird das denke eine richtig feine Sache und DreamOS ist default HD und fullhd mit den meisten Sachen abgedeckt.

    Alles wird klar nicht in fullhd default sein weil da müssten dann auch die Pluginersteller selbst mit machen aber viele Sachen und das ist dann ja schonmal ein guter Anfang.

  • gutemine Hier bitte haste das Vali EPG Plugin ,das dann default jetzt ein wenig aufgfrischt wurde und halt auch Fullhd support hat.

    Kannst ja dann daraus ein aktuelles Pluginpaket bauen für die User die es gern haben möchten.

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von zombi ()

  • Danke, ich mache draus ein deb, du kannst den Anhang wieder entfernen


    Jetzt wo der default FHD Skin im e2 dabei ist geht es ja relativ leicht.


    EDIT: auf der ersten Seite ist jetzt eine Version 1.3 mit deem angepassten HD/FHD skin von zombi, nochmals Vielen Dank!


    gutemine

  • Ok bitte aber die Abhängigkeit zum aktuellen e2 nicht vergessen .

    Wer das Plugin in einem fullhd nutzen möchte der sollte die dazu gehörige skincomponente noch in seinen skin machen .

    Diese gibt es im neuen Default-fullhd ,wenn der default fullhd mal master ist für fullhd Skins muss man die components nicht mehr extra in seinen skin machen ,das wird dann automatisch aus dem default fullhd genommen.


    <component itemHeight="80" iconHeight="30" iconWidth="30" itemMargin="10" textHeight="35" timeWidth="240" eventHeight="34" eventWidth="460" type="newEPGlist" />

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von zombi ()

  • hmm.. du hätest das Paket von zombi 1:1 nehmen können.

    In deinem oben ist der ganze alte Krempel an png's und Componenten mit drinn, der gar nicht mehr gebraucht wird.


    das reicht vollkommen aus

  • ich wollt ja schon ehr .. hat ja aber geheisen noch nicht .. wegen .. was auch immer :)


    Mir ist zB. auch jetzt erst aufgefallen, das man den Converter piconRefString überhaupt nicht mehr brauch. Hab denn auch aus meinem Skin entfent.

  • Hi,

    Ich habe versucht das Paket aus #Post 31 zu installieren. Kein Fehler.lässt sich aber nicht aufrufen, oder mache ich was falsch.


    Ich habe die DM 900

    Gruß

    Kimba

  • Ich habe auf die erste Seite einen neueren Kit gemacht wo ich den Dummy Support für die Record Taste reingemacht habe, als Vorausetzung damit das Instant EPG Timer Plugin dann in der nächsten Version auch mit Vali's EPG funktionieren wird.


    LG

    gutemine

  • Hallo,

    nach dem gestrigen update läßt sich Vali's EPG bei mir leider nicht mehr aktivieren. Habe aber auch noch nicht herausgefunden, woran es liegen kann. Ich nutze es aber sehr gerne. Kann jemand helfen?

    Gruß, Renard