dFlash und dvbModul

  • Hallo,


    ich habe eine Dream 7020HD mit 2 Doppelreceivern S2 und mit neustem Experimental OOzoon Image.


    Erstelle ich ein nfi-Backup mit dFlash, dann klappte dies noch Anfang des Jahres, neuere Backups können aber mehr zurückgespielt werden.Die erstellten Images sind 88MB groß. Was beim Rückspielen auffällt: Die Dreambox flashed die ersten 8% ganz langsam, danach geht es ganz schnell. Boote ich danach, dann startet der Bootloader, aber dieser findet keine Root Partition und es wird nach 3 MInuten ein Neustart der Dreambox herbeigeführt.



    In meinem Image ist installiert dreambox-dvb-modules - 3.2-dm7020hd-20151201-r7.0. Damit gehen einige Sender nicht in Kombination mit dem ciplus-Modul, wie z.B. Sky Universal und Pro 7 Fun. Es gibt ein Update des Modules dreambox-dvb-modules_3.2-dm7020hd-20160531-r7.0_dm7020hd.ipk für NewEnigma. Installiere ich es, dann gehen die Sender, aber ich kann nur noch mir meinem ersten Doppelreceiver S2 etwas empfangen.


    Kann mir jemand bei meinen Problemen helfen?


    - Fire

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von fire ()

  • dFlash schreibt beim sichern ein log auf /tmp ohne das ist es sinnlos zu raten was dein problem sein koennte. Wahrscheinlich hast du auf loader 89 aktualisiert ohne das nfiwrite zu aktualisieren womit das Sofaflashen nicht geht.


    Die neuesten treiber sind nur fuer aktuelles experimental ohne das geht's nicht.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Ich habe in der Tat den Loader 89.


    Installiert ist 0imageupdate version 20160117-r0, nfiwrite version 1.7, nfidump 0.16. Sind das nicht die neusten Versionen? Nach einem Backup steht in dbackup.log


    Ich habe probiert das Zurückspielen sowohl bei Webinterface, Enigma-Menü an der Dreambox selbst sowie über das Booten des NFI-Flash. Alles geht nicht.

  • Nein, das sind NICHT die aktuellen Versionen und du solltest dich mal mit der Einstellung Extract Loader from Flash im dFlash befassen, weil ohne Loader wird dir ein Backup wenig nützen ...

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Danke für die schnelle Antwort. Habe jetzt Extract Loader from Flash auf Ja gestellt. Diese Option ändert nur was, wenn ich ein Backup über den Fernseher zurückspiele oder auch wenn ich es über das Webplugin von dFlash mache? Oder hat die Option was mit dem Sichern zu tun?


    Wenn ich mit anschaue hier im Board, was das neuste Image für DM7020HD ist, dann finde ich unter
    http://www.oozoon-board.de/wbb/index.php?page=Board&boardID=13
    nur das Image 20151206.nfi, und dort habe ich dann alle Updates eingespielt, die meine opkg.conf hergibt:


    # all feed
    src/gz oozoon-all http://update.oozoon.de/opendreambox/2.0/experimental/all
    #mips32el feed
    src/gz oozoon-mips32el http://update.oozoon.de/opendr…2.0/experimental/mips32el
    # dm7020hd feed
    src/gz oozoon-dm7020hd http://update.oozoon.de/opendr…2.0/experimental/dm7020hd


    Soll ich mir neuere Versionen selbst zusammensuchen, z.B. auf dreambox-tools.info gibt es nfidump_0.17_all.ipk
    oder was sollte in opkg.conf stehen?

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von fire ()

  • Du solltest vielleicht mal drüber nachdenken wo nfiwrite oder nfidump herkommt - es gibt hier im Board den offiziellen Kit und Support Thread dazu ...


    Und NEIN ich bin nicht die Board Suchfunktion um diese zu finden.


    Alle andere hat OoZooN aktuell am Feed, bzw. schon in seinem Image fix verbaut, du musst es also NICHT nachinstallieren.


    Schau in dein log vom backup nachdem du extract loader auf ja gestellt hast, dann wirst du sehen das mit nanddump der loader jetzt extrahiert wird und das jetzt erstellte nfi sollte auch auf jede erdenkliche weiuse geflashed werden können, ausser es ist > 128MB dann benötigst du das aktuelle nfiwrite 1.10 und kannst es nur mehr mit dFlash selbst Flashen.


    Und das der Laoder extrahiert wird ist für das SICHERN wichtig, sonst hast du ein Image ohne Loader das mit gar nix geflashed werden kann wie du ja selber rausgefunden hast.


    Und das nand check binary is bei OoZoonn auch auf dem Feed bzw. bereits im Image verbaut.


    ich weis nicht ob OoZoon bei seinem 7020hd image bereits den Feed aktualisiert hat so dass das letzte enigma2 und die letzten Treiber durch Softwareupdate installierbar sind, da ich keine solche box mehr habe.


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Die wichtigste Info vorab: Es geht jetzt.

    Du solltest vielleicht mal drüber nachdenken wo nfiwrite oder nfidump herkommt - es gibt hier im Board den offiziellen Kit und Support Thread dazu ...

    Ich weiß, dass es von Dir kommt und bin echt froh über deinen 2.0Image Support. nfidump/write ist der Grund, warum ich das oozoon-Image nutze. Die Suchfunktion hatte ich genutzt, weil ich nicht wußte, dass es nur darum ging, nfiwrite und nfidump zu aktualisieren. Jetzt habe ich:


    opkg list |grep ^nfi
    nfibuild - 0.3 - nfi Dreambox image build tool <-------- Sollte ich hier auch etwas neueres installieren?
    nfidump - 0.16 - nfi image extractor
    nfidump - 1.0
    nfiwrite - 1.7 - nfiwrite for Dreamboxes
    nfiwrite - 1.10


    Keine Ahnung, warum die Paketverwaltung noch immer glaubt, dass nfidump - 0.16 und nfidump - 1.0 drauf sind. Beim Installieren hatte opkg gesagt, es wird geupdated. Ruft man nfidump auf, dann ist es jetzt version 1.10. "nand check binary" habe ich installiert, der Check zeigt jetzt was an. Danke.


    Im log kann ich aber noch immer nichts von "loader" finde. Was genau hat sich durch die geänderte Option im Log geändert?


    Vielen Dank nochmals.

  • Eigentlich hast du nur Schrott installiert. nfibuild ist ein standalone tool das mit dFlash nichts zu tun hat.


    nfidump ist mit dem aktuellen dFlash 13.7 gar nicht mehr nötig und beim nfiwrite hast du scheinbar mal 2 kits im /tmp gehabt womit du dir die opkg status databse kaputt gemacht hast.


    Und ich habe doch geschrieben das im log jetzt eine Zeile mit nanddump stehen muss wo der loader extrahiert wird ...


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Ich bekomme als Antwort beim Aufruf von
    opkg list-installed|grep ^nfi
    nfidump - 1.0
    nfiwrite - 1.10
    Alles andere habe ich gar nicht installiert. Meine opkg status database ist hoffentlich doch nicht kaputt. Das ganze war mir aufgefallen, als ich probierte nfibuild zu entfernen.


    Habe nfidump und nfiwrite aktualisiert, weil ich glaubte, beides aktualisieren zu müssen ... sagtest ja, ist nicht aktuell :-)
    Eine Zeile
    /usr/sbin/nanddump --noecc --omitoob --bb=skipbad --truncate --file /media/hdd/backup/s.bin /dev/mtd1
    habe ich jetzt gefunden.


    Ich frage mich, wie/warum der Parameter "Extract Loader from Flash" sich bei mir auf "Nein" gestellt hat. War besonders schwer für mich zu finden, weil ich eigentlich nur übers Webinterface mit dFlash Backups mache, und da gibt keine Einstellungen.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von fire ()