mit dm8000 auf die FP der dm920 zugreifen

  • Hallo zusammen,


    ich möchte mit der dm8000 auf die Festplatte der dm920 zugreifen. Nachdem dank der Hinweise, die ich auf meine Anfrage vom 01.01.18 erhalten habe, läuft auf beiden Boxen der Netzwerkwerkbrowser installiert ist, habe ich folgende Zugriffe:

    - von dm8000 und dm920 auf die Synology NAS

    - von dm920 auf die FP der dm8000


    was nicht geht, ist, von der dm8000 auf die FP der dm920 zuzugreifen.


    Ich kann im Netzwerkbrowser der dm8000 die dm920 sehen, aber auf die Platte zugreifen kann ich nicht. Hierzu Bild "freigabe dm8000" in der Anlage.


    Bei der dm920 ging es ohne Probleme (Bild Freigabe dm920) und es funktioniert auch, sowohl über das Mediacenter als auch über den Mediaplayer.

    Es fällt auf, daß die dm8000 (feste IP 192.168.178.98) 2x aufgeführt ist, als nfs und als smb.


    Kann es sein, daß mir auf der dm8000 noch ein plugin fehlt? Wäre für einen Tip dankbar.


    Danke und Gruß


    Wolf


     



  • du wirst auf der dm9x0 ein /etc/exports file brauchen wo die Platte auch drinnen steht sonst wird nichts exportiert


    In telnet:


    apt-get install nfs-utils


    und dann den befehl exportfs eingeben, wenn das nichts anzeigt ist auch nichts exportiert.


    Mit einem exports file das deine Harddisk für dein lokales netzwerk freigibt - sofern dein router 192.168.x.x adressen vergibt:


    Zitat

    root@dm920:~# cat /etc/exports

    /media/hdd 192.168.0.0/255.255.255.0(rw,async,root_squash)

    root@dm920:~# exportfs

    /media/hdd 192.168.0.0/255.255.255.0


    Und mit cifs/sama wirst du die box nur mounten können wenn der sambaserver auch installiert wurde - deswegen siehst du die 8000 wahrscheinlich mit beiden weil das dort passiert ist.

  • Wolf49 ,

    ein Thread zum Thema reicht, den anderen habe ich gelöscht.


    Und noch ein Tipp.


    Die Bilder die du mit dem Handy oder Fotoapparat gemacht hast sehen nicht so toll aus.

    Einfacher geht es doch mit dem Webinterface unter Steuerung.


    ps.


    Du solltest auch schon in deinem Beitrag erwähnen das du das GP3 Plugin verwendest.

    Wir haben hier ja keine Kristallkugel,

    außerdem testen wir unser Image nicht mit dem Plugin.;)

  • OK, ist alles angekommen, auf den doppelten Thread hatte mich gutemine auch schon hingewiesen, ich weiß nicht, wie ich das hingekriegt habe...


    Kannst Du den Thread bitte in /Dreambox Plugins/Plugins (DreamOS) verschieben, dort gehört er m.E. ja hin. Vielen Dank

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Wolf49 ()

  • gutemine

    1. nfs-utils installiert

    2. nach Eingabe "exportfs" in Telnet wird nichts angezeigt.

    3. das file exports gibt es in /etc nicht. Habe ich angelegt, dann versucht die Telnet Befehle abzuarbeiten. Kommt aber eine Fehlermeldung unterhalb



    Danke nochmals für Deinen support - alleine bekomme ich das nicht hin.


    Mein System:

    dm920

    Dreambox OS 4.3.1r23-2017-12-16

    (Oozoon)Image: Experimental 2017-12-17

    GP 3.3

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Wolf49 ()

  • nein


    Bitte mache das um das file zu löschen:


    Code
    1. rm /etc/exports


    Und dann nochmals den echo Befehl aber GENAU mit cut and paste inklusive der Anführungszeichen:


    Code
    1. echo "/media/hdd 192.168.0.0/255.255.255.0(rw,async,root_squash)" > /etc/exports


    exports gibt dir nur die exportierten alias der shell aus, der Befehl lautet exportfs und sollte nach dem installieren der nfs-utils auch vorhanden sein.

  • Hallo und guten morgen


    habe es nun nach Anleitung gemacht, exports per befehl gelöscht und mit Befehl echo.... neu angelegt.


    in der exports steht nun:

    1 /media/hdd 192.168.178.98/255.255.255.0(rw,async,root_squash)


    wenn ich nun den befehl exportfs eingebe, passiert nichts. nfs-utils sind installiert.

    Auch wenn in Zeile 2 unterhalb nicht der komplette Befehl steht, den Du mir gegeben hast, habe ich diesen mit copy und paste (incl. echo usw.) komplett eingefügt.



  • Bei mir gehts auch ohne Leerzeichen.


    Hast du nach dem anlegen des files auch rebootet ?


    Hast du auch die entsprechenden kernel module installiert:


    apt-get update

    apt-get install kernel-module-nfsd


    Ich vergesse die immer weil BA die sowieso als dependencies erzwingt ...


    Der Befehl ps ax | grep nfs muss nach dem reboot auch eine entsprechende Anzahl von nfs daemons am server auflisten:


    ps ax | grep nfs

    32 ? S< 0:00 [nfsiod]

    262 ? S< 0:00 [nfsd4]

    263 ? S< 0:00 [nfsd4_callbacks]

    267 ? S 0:08 [nfsd]
    268 ? S 0:09 [nfsd]
    269 ? S 0:00 [nfsd]
    270 ? S 0:00 [nfsd]
    271 ? S 0:00 [nfsd]
    272 ? S 0:00 [nfsd]
    273 ? S 0:05 [nfsd]
    274 ? S 0:06 [nfsd]

    9427 pts/0 S+ 0:00 grep nfs


    Langsam bin ich am Überlegen ob wir nicht ein nfs-exports deb auf den Feed legen sollten wo nur ein fertiges /etc/exports file drinnen ist. Oder ich könnte ins Userscripts Plugin eine enable nfs exports Einstellung machen die das file für Euch schreibt.

  • So, hab nun alles abgearbeitet.


    1. reboot war notwendig, nun kommt bei exportfs




    Sieht bisschen komisch aus mit dem großen Freiraum zwischen hdd und der IP


    2. apt-get update durchgeführt.

    3.


    Resultat: ich sehe nun im media player der dm8000 unter network mount das Verzeichnis "dm920", aber - leider - es ist leer!!

    Beide Boxen wurden gebootet.


    Nachdem ich ja aus dem media player auf meine NAS-Dateien zugreifen kann, glaube ich mal nicht, daß es ein Problem der dm8000 ist. Allerdings sind die NAS-Verbindungen der dm8000 in der auto.network hinterlegt.


    ich wäre sehr dankbar, wenn es noch einen Tip gibt. Vielen Dank.


    Nachtrag: ich habe in der exports mal den Pfad auf media/hdd/movie erweitert, weil dort die Filme liegen, allerdings ebenfalls ohne Erfolg.

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Wolf49 ()

  • MOUNTEN wirst du jetzt schon auch noch müssen - wirf jetzt den Netzwerkbowser nochmals an und schaue mal ob dd bei der 920 jetzt was aufklappen kannst ... dann verbinden ....


    Der Netzwerk export funktioniert jetzt aber schon mal ... und ja der Abstand ist richtig so ...

  • Leider kein Erfolg.

    NetzwerkBrowser neu gestartet, neu die Verbindungen suchen lassen und die cfis- und die nfs-Verbindung aktualisiert. Bei beiden Verbindungen hat das Festplattensymbol ein rotes Kreuzchen und im Media Player bleibt das Verzeichnis dm920 leer.

  • MOUNTEN wirst du jetzt schon auch noch müssen - wirf jetzt den Netzwerkbowser nochmals an und schaue mal ob dd bei der 920 jetzt was aufklappen kannst ... dann verbinden ....


    Der Netzwerk export funktioniert jetzt aber schon mal ... und ja der Abstand ist richtig so ...

    gutemine :

    ich habe noch mit den vorgenommenen Einstellungen herumprobiert.

    Ich weiß nun, daß ich mit meinem Fernseher (Sony Bravia) Zugriff auf die FP und die aufgenommenen Filme auf der dm920 habe (auch wenn der Fernseher das ts-Format nicht kann, sehe ich doch die Dateiauswahl.

    Ich denke mal eher, daß es dann doch ein (EinstellungsProblem bei der dm8000 ist.


    Ich werde aber meinen Frieden damit machen, da ich ja mit der dm920 Zugriff auf die Aufnahmen der dm8000 habe, und das hat für mich Priorität.


    Also nochmals vielen Dank für Deine sachkundige Hilfe. :thumbup:


    Gruß

    Wolf

  • Langsam bin ich am Überlegen ob wir nicht ein nfs-exports deb auf den Feed legen sollten wo nur ein fertiges /etc/exports file drinnen ist. Oder ich könnte ins Userscripts Plugin eine enable nfs exports Einstellung machen die das file für Euch schreibt.

    Hallo gutemine,


    hast Du Deine Idee vom 05.01.18 (oberhalb) weiter verfolgt?


    Möchte das Thema nochmals angehenund den Zugriff der dm8000 auf die FP der dm920 herstellen (umgekehrt geht es ja).


    Stand ist immernoch so, das ich im MediaPlayer der dm8000 unter network mount das Verzeichnis "dm920" sehe, aber das ist leer, also augenscheinlich kein Zugriff auf die FP der920.


    Vielen Dank