Mr. Big (Flash) für DreamOS

  • Irgendwie es es komisch - ich habe jetzt 5x hintereinader mit dBackup 0.94 eine mit Mr. Big (Flash) von USB gebootete dm525 geflasht und es ist kein einziges mal schief gegangen.


    Wo lag denn deine dBackup Sicherung hast du mit tar.gz oder tar.xz gesichert ?


    Ich verwende die Default Setings im dBackup also tar.gz und eine auf /media/hdd gemountete Restpartition von Mr. Big für die Sicherung, welche nach dem Restore genauso wie /data wieder wunderbar gemountet wird, da ja analog zum Image im Flash nur das root Filesystem neu geschrieben wird.

  • Also nachdem kaum mehr Input kommt habe ich das Mr. Big (Flash) Plugin erstmal in einer Version 1.0 released.


    Auf den nicht-dm52x wird jetzt auch nach ein paar Sekunden im Plugin erkannt ob der Partitionslabel zum aktuellen layout passt und das kep data beim on-the-fly resize der root partition von 1GB auf 2GB kann man jetzt auch nicht mehr auswählen, es bleibt also bis auf weiteres nur die root Partution erhalten.


    Das klassische Umstellen mit Backup und dann Restore im Rescue Loader, wo man sich eben nur den 2GB oder 1GB Partitions Label für den Flash schreiben kann auf Gelb und Blau und man dann direkt in den Rescue Loader bootet, gibt es natürlich weiterhin. Für die dm52x mit USB gibt es allerdings nichts neues in der 1.0 zu der vorherigen Versionen.


    Mal sehen ob und was Ihr da noch an Fehlern findet, sonst bleibt es erstmals so.


    Viel Spass mit Mr. Big (Flash) für DreamOS.


    LG

    gutemine

  • ich hatte die Sicherung nach /data gelegt, da keine Restpartition vorhanden, die Sicherung war tar.gz und keine Ändeurngen in dbackup vorgenommen.

    Ich bin aber leider nicht zu weiteren Tests gekommen, Frau und Tochter sind krank, da muss ich etwas mehr im Haushalt machen ;)

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Jogi29 ()

  • danke, werde ich ausrichten, geht den Beiden aber schon wieder besser, zjm Glück bin ich von dem Mist bisher verschont geblieben.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"

  • ich konnte heute noch ein wenig testen, 1x meine DM525 und 2x DM520, alle 3 Boxen mit einem Intenso 4GB USB-Stick.

    Ich habe es auf keiner Box geschafft, das zuvor mit dBackup 0.94 vom USB gesicherte Image auf einen andern USB-Stick zu bringen.

    Ich habe also eine Box vollstänsig eingerichtet, damit sie von USB startet, dann habe ich eine Sicherung mit dBackup 0.94 mit .tar.xz erstellt, auf den PC kopiert. DIe 2. Box angeschlossen, eingerichtet dass sie auch von USB startet, Sicherung nach /data kopiert und mit dBackup den Flashvorgang (nicht WebIF) gestartet, leider tut sich auch nach mehreren Minuten nichts, es kommt halt die Meldung, dass dBackup beschäftigt ist.



    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"

  • also ich hab eine 7080 und enigma2 4.3.1 r25 eingespielt dann mr big und stimmt es dann einfach gelb drücken und warten

  • Nein, damit schreibst du nur den 2GB Label, er fragt dann sofort ob du in den Rescue loader booten willst und dann müsstest du ein backup restoren das du hoffentlich vorher gemacht hast.


    Wenn du live und on-the-fly und ohne backup und restore auf 2GB Flash resizen willst musst du Resize auf Grün verwenden, maximal kann es dann auf den nicht 9x0 wegen älterem Kernel passieren das du einmal rebooten und es nochmals machen musst bis der Vorgang abgeschlossen ist., dabei wird zwar data gelöscht aber das rootfilesystem wird einfach vergrößert.

  • danke für die antwort kann ich dann ein backup verwenden das ich mit dflash gemacht hab

    grün ist ja usb kernel und gelb wär ja flash kernel wie gesagt für die 7080hd

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gunnar11 ()

  • ich hab's auch auf einer DM920 und einer DM900 gemacht, schnell und problemlos. Schon erstaunlich, dass sowas bei laufendem Betrieb und ohne Neustart funktionniert.


    DIe Änderung ist ja permanent, danach kann man also, wenn man keine andere Funktion des Plugins benötigt, dies desinstallieren?

  • Hallo alle. :)


    Ich schreibe mal mein Problem hier rein, obwohl es womöglich eher in den dBackup Thread gehört.

    Evtl. meine Frage in den dBackup Thread verschieben.


    Habe MR.Big (enigma2-plugin-extensions-mrbig_0.10_all.deb ) auf meiner DM920 mit Merlin4 benutzt und den Flash auf 2 GB erweitert. Picons und Movie.db anschließend zurück nach /data geschoben. Muss alles keinen Zusammenhang mit Folgendem haben:


    Überprüfe ich ROOT mit dBackup bekomme ich Folgendes:



    Überprüfe ich irgend etwas anderes, wird abgebrochen.



    Da dBackup trotz installiertem e2fsprogs-e2fsck bemängelt hatte, dass e2fsprogs fehlen würde, habe ich in der Paketverwaltung noch weitere e2fs...Kopmponenten installiert



    Obige Fehlermeldung zum Superblock bleibt aber bestehen.



    Frage:

    Wie kann ich das reparieren?

    Kann ein Rückbau von 2GB Flash zu 1 GB (weil´s eigentlich reicht) mit Mr.Big heilsam sein oder evtl. alles verschlimmbessern?


    Meine 920 war anfangs sehr zuverlässig. Jetzt hat sie inzwischen 1x beim Booten gehangen und hat sich auch einmal bei einer Timeraufnahme komplett aufgehängt.


    (Sollte es nötig werden: wie starte ich e2fsck mit einem alternativen Block und was muss ich bei <device> eingeben? Etwa in telnet "e2fsck -b 8139 root" ?)

  • Kannst du es vielleicht einfach RICHTIG machen?

    /dev/mmcblk0p1 ist das raw device wo der Kernel liegt, da ist gar kein Filesystem drauf, also ist auch nichts zu checken.


    Das resizefs um auf Grün on the fly zu resizen ist zwar nicht 100%ig, funktioniert aber normal recht stabil.

    Wenn du dem Filesystem nicht traust, dann mache ein Backup und flashe damit einfach die box neu mit dem rescue Loader, dabei wird das Filesystem komplet neu gemacht und die 2GB bleiben erhalten. Beim Sofaflashen mit dBackup wird hingegen immer nur das vorhandene Filesystem geleert und neubefüllt.

  • Danke Jogi29


    Ich hatte die 0.10 benutzt, weil die zu dem Zeitpunkt aktuell war. Jetzt habe ich die 1.0 drauf.

    Wurde automatisch vom Merlin Feed upgedated, wie ich eben feststellte, nachdem ich das file von hier aus Post #2 nach /tmp auf meine 920 schob und die Installationsroutine dann 0 upgrades meldete. ;)


    Danke gutemine  :)


    Zum Teil bin ich beruhigt, zum Teil auch nicht. Habe heute ein (dBackup) Backup von gestern neu geflasht.

    (Box in Standby, dann stromlos, Straom an und Finger beim Start auf Folientatste. Dann Firmwareupload über Webbrowser ohne Sicherung und Wiederherstellung von settings, weil ja schon im Backup drin).


    In dbackup mit Überprüfen keine Änderung. Dann also Telnet bemüht. Habe allerdings an einer Stelle abgebrochen (wo man /data umounten würde), weil bei mir zuvor ein anderes Ergebnis rauskommt als bei Dir.

    Meldungen auf Deutsch, weil ich e2fs....locale.de installiert hatte (Screenshot in meinem Post oben).


    Code bei mir



    Muss ich mir da jetzt Sorgen machen?

    Muss/kann da was gefixt werden oder darf es so bleiben?

  • Hallo gutemine :)


    Habe die Box gerade eben aus dem Standy (üblicher Zustand bei Nichtbenutzung) hochgefahren und jetzt wurde /data korrekt erkannt.


    Das Verrückte allerdings: /data muss heute Morgen ebenfalls korrekt gemounted gewesen sein, wurde aber dennoch nicht zu 100 % erkannt.


    Wie komme ich zu diesem Schluss?

    Meine picons und movie.db liegen auf /data und beide funktionierten zu dem Zeitpunkt als der Telnet Befehl "e2fsck -n /dev/mmcblk0p3" die Partition nicht fand.


    Ähnliches lag vor Kurzem möglicherweise (???) vor, als eine externe USB 3.0 HDD (passiv ohne Netzteil, ausgebaute 2.5 HDD aus alter DM8000 in USB Gehäuse eingebaut) mit EXT3 angeschlossen war.

    Die Festplatte ging normal mit Wiedergabe und Aufnahme, ließ sich aber im Gerätemanager nicht aushängen, weil sie angeblich ein "Unbekanntes Dateisystem" hatte.

    Ich fuhr meine 920 in Standby, machte sie stromlos um ganz sicher die HDD abzustöpseln. Strom wieder an und im laufenden Betrieb HDD angestöpselt und, siehe da, das Dateisystem war plötzlich wieder "bekannt EXT3".


    Irgendwie scheint also das Dateisystem von Partitionen bei meiner 920 manchmal nicht vollständig (teilweise schon, da ja die Partitionen funktionieren) erkannt zu werden.

    Vielleicht irre ich mich da auch. (?)

    Jedenfalls, keine Ahnung, was da vorliegt. Es dürfte aber wohl kaum etwas mit Mr. Big zu tun haben. ;)

  • dann hast du ein Probem mit dem Anlaufstrom der Platte, aber das ist nichts was man nicht mit einem aktiven Hub mit USB Netzteil fxen könnte. Und nein das hat dann weder was mit dem 2GB großen Flash noch Mr. Big zu tun.