Final Release Candidate Kits vom EPGLoad Plugin

  • hei hei gutemine ...


    wenn ich dieses plugin installiert habe kann ich nicht mehr updaten... dann kommt diese meldung:


    führe ich dann "apt-get -f install" aus... kommt folgende meldung:

    würde mich freuen wenn du mir das problem löst, weil ich dieses plugin für genial halte... --gruss--


    luigi13

  • ok... ich eiere auf der 900 nun 3 std. herum... "python-izma" werde ich nicht los... und

    "python-backports-izma" bekomm ich nicht installiert...


    habs dann auf der 7080 in 5 min. hinbekommen.... hätte es gerne auf der 900 auch am laufen

    habe inzwischen ein backup eingespielt, hilft alles nix... hier die auszüge aus "remove" & "install":


    deinstallversuch von apt-get remove python-lzma:


    install-versuch von python-backports-lzma:


    watt nu? apt-get -f install ergab das:


    UND... epg import bekomm ich auch nicht deinstalliert.... versuch ergibt das:


    Zitat
    Code
    1. Reading package lists...
    2. Building dependency tree...
    3. Reading state information...
    4. You might want to run 'apt-get -f install' to correct these:
    5. The following packages have unmet dependencies: enigma2-plugin-extensions-epgload : Depends: python-backports-lzma but it is not going to be installed
    6. E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


    ich dreh mich i.-wie im kreis.... --gruss--


    luigi13

  • so jetz gings... hab nochmal das backup eingespielt, sofort upgedatet, sofort "python izma" deinstalliert... ging

    dann sofort "backports" über webadmin installiert... ging... also alles gut hier...


    keine ahnung was hier los ist/war.... sry and happy weekend


    luigi13

  • Servus


    Bin neu hier und habe eine Dreambox one UHD gekauft.


    Nun Suche ich verzweifelt EPG und Picons für IPTV.


    Glaube dieses Tool wäre das richtige oder?


    Gibt es eine Installationsanleitung?


    Denn meine Frage ist, muss ich beide Dateien auf die Box machen oder nur eine?


    Danke für die Hilfe und Sorry für das Unwissen meinerseits.

  • Danke fürs Testen, weil besser kriege ich es mit dem wenigen Input von Euch leider nicht hin. Mein Ziel war und ist ja das es crashfrei läuft und alle Fehler sauber gehandhabt werden, nicht so wie beim Mitbewerber wo mit try/except alles niedergeprügelt wird.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • hei hei gutemine...


    kurze rückmeldung: als ich gestern nach hause kam war der tv an, auf der DM7080 keine epg-daten mehr,

    die epg-db war defekt, nach neuanlegung der epg-db mit der rec-taste wurde wieder epg gesammelt....


    heute auf der 900 in etwa das gleiche... der tv war an, epg leer -nur- nach anlegen einer neuen epg-db

    mit der rec-taste ging das neuladen von epg-daten dann aber trotzdem nicht...


    beide boxen auf 1x am tag suchen eingestellt... wenn du i.-was brauchst, log oder so, müsste ich nur wissen

    "wie"... weil ich ja nicht weiss wann die epg-suche startet... --gruss--


    luigi13


    was ich eig. damit sagen will ist: die "erstmalige" (manuelle erste suche) läuft anstandslos durch...

    i.-was ist dann nicht ok mit der "epg-aktualisierung" --> 1 tag....

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von luigi13 ()

  • Einfach dann das E2 Log in ein File schreiben lassen und Posten. Nicht vergessen das Ähnliche Sender nicht für Dauerbetrieb gedacht ist und das man bei größeren epg.db evt. den delay auch verwenden muss und evt. auch andere vor der Suche löschen Einstellungen benutzen sollte.


    Wie gross wird denn deine epg.db und wie gesagt Log sollte mehr wissen...

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • ja.... auf der 7080 manuell das plugin gestartet heute morgen --> epg war da für 1 woche... das war gestern nicht so... vllt. sollte ich "behaupten" das wenn man das plugin manuell startet, das es funzt...

    -nur- eben dann wenn automatisch/selbstständg geladen werden soll (z.B.: 1x am tag)... das es dann eben nicht lädt....



    keine ahnung wie ich das mitloggen soll, weil ich eben nicht weiss wann das plugin die suche startet...

    ich sammle erotik, DACH, norwegisch & englisch... epg.db 101.558.272 mb gross (bei epg.import war die grösse bei ca. 180 mb)



    ich hab mal das log von heute angehängt, obwohl es dir nichts sagen wird da ja geladen wurde...


    enigma2.log

  • Das ist wirklich ziemlich gross, dann braucht auch das speichern und laden relativ lang. Ich schaue mir am Abend das Log Mal an...


    Bitte auf jeden Fall mit der Verzögerung automatisch laden testen, weil du hast warte herunterladen noch auf nein.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • ja gut.... habs auf 30 sek. eingestellt... (?)


    also, das wir nicht aneinander vorbei sprechen,... das manuelle laden scheint zu klappen...

    -nur- das im plugin einstellbare "alle 6 std., 12 std., 1x am tag" löscht die epg daten (nix mehr da)

    und im schlimmsten fall ist die epg.db kaputt oder der TV an... das würde ich gerne mitloggen...


    luigi13

  • also, es scheint wohl geholfen zu haben das epg laden nach 60 sek. einzustellen... auf beiden boxen 900 & 7080

    habe ich neuen epg für eine woche... werd ich weiterhin beobachten (das war die letzten tage nicht so)...


    dann hab ich versucht epg-load auf die 8000er zu bekommen... fehlt wohl "python-izma"... ist (für mich) unmög-

    lich das auf die box zu bekommen, versucht mit webadmin... so als kleines feedback.... du hattest mal drum

    gebeten das bei oe 2.0 boxen zu testen....

    wenn du mir sagst wie ich das auf die box bekomme, teste ich weiter...


    luigi13


  • Das ist primär für Open* Images auf aktuellen boxen, ob es das backported lzma bei OE 2. überhaupt noch wo am Feed gibt, keine Ahnung, wahrscheinlich müsste man das aus dem Open* Feed borgen,... weiß nicht ob das noch sinnvoll ist.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Der Download dauert auch nicht länger, die Dauer des laden in die EPG.db hängt von den Einstellungen ab, wenn du ähnliche Kanäle verwendest wird es z.B. sofort 3-4x langsamer sein, dafür musst du kein lokales Channels File basteln oder kannst es dir damit erstellen lassen, etc. Wenn ich nur meine Favoriten lade ist es sogar flotter.


    Und du kannst nicht einstellen alle x Tage oder Stunden laden, sondern EPG soll nicht älter sein als x Tage oder Stunden, weil das sinnvoller ist.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • hei hei....


    ich schreib mal hier rein weils ja um die install. dieses plugins geht... DM900, Merlin-image...

    ich musste ein backup einspielen und bekomme dort nicht "python-backports-izma" eingespielt, welches ich ja

    für dieses plugin brauche... hatte alles damals geklappt, weiss aber nicht mehr "wie" ich das gemacht habe...


    im anhang install-versuch vom plugin und python-backports-izma... --gruss--


    luigi13


  • Die Frage wurde im Thread bereits gestellt und auch beantwortet. Alte Lzma Python Pakete deinstallieren damit vom Feed die richtigen genommen werden oder mit force Overwrite die neuen drüber installieren

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • upps... das war ich ja selber vor 4 wochen... lol (im strudel des abgrunds)

    aber eine lösung gab`s da nicht wirklich... in den posts von mir vor dem hier zitierten spiegeln genau das

    szenario wieder welches ich hier heute wieder mitmache...


    wie lautet denn der telnet-befehl mir "force-overwrite"?

    weil ich das python-izma nicht loswerde, sry...


    luigi13

  • heute das versucht:

    wäre echt nett wenn mir mal jemand sagen könnte was hier unkorrekt ist...


    luigi13


    ach ja.... über softwareverwaltung --> paketmanager werde ich python-izma auch nicht los... s.pic.


  • Auf dem Standardfeed vom DP gibt es NUR das python-backports-lzma und daher ist auch NUR dieses in den dependencies.


    Wenn ein anderes Image das anders handhabt ist das nicht mein sondern Euer Problem - Lösungsmöglichkeiten gibt es genug und sind auch alle bereits hier im Thread nachzulesen.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • also, wenn du es denn nochmals niederschreibst wie man das eine (python-izma) los wird... oder mit

    "overwrite" das andere (python-backports-izma) doch noch auf die box bekommt dann schadet das doch

    niemanden, oder?


    wäre wirklich sehr nett von dir... (ich las durch den ganzen thread hier, keine lösung gesehen)


    luigi13

  • Das force Overwrite gilt nur für das Paket das du installierst, das vererbt sich nicht auf dependencies....


    Wenn dir das zu kompliziert wird kannst du die lzma Pakete auch einfach im /var/lib/dpkg/status File löschen.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Hallo,

    zunächst einmal vielen Dank für das tolle Plugin. Super Arbeit!


    Ich habe an diesem verregneten Sonntag mal versucht, dieses Plugin bei mir auf der DM920 zum Laufen zu bekommen.

    Ich hab soweit alles hinbebommen, jedoch fehlen die Sender RTL II HD, Nat GEO HD und RTL UHD, wobei letzerer eher unwichtig ist.


    Was mache ich falsch?? Hat jemand einen Rat?

    Strauchele ich bei den "similar_channels.xml"?? Ich habe Ähnliche Kanäle auf "laden" und unter /etc/epgload folgende similar_channels:


    Kanalreferenzen bei mir:

    RTL II HD

    1_0_19_EF15_421_1_C00000_0_0_0


    Nat GEO HD

    1:0:19:70:D:85:C00000:0:0:0


    RTL UHD

    1_0_1F_307A_3F5_1_C00000_0_0_0


    Vielen Dank für die Hilfe,

    rako123

  • Hallo Arki,
    da hast du natürlich recht. Die Sender gibt es auch über Sat EPG.
    Ich würde mich trotzdem freuen, wenn ich den Fehler finden würde, warum ca. 250 Sender funktionieren und genau die oben beschriebenen NICHT funktionieren.

    Ich ärgere mich, dass ich es nicht hinbekomme.


    Vg und Danke, rako123

  • Erstens wirst du wenn du nicht Ähnliche aus Save stellst gar kein similar channels file kriegen und zweitens sind die sowieso mit den SAT versionen im standadard Rytec file enthalten.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Hallo gutemine ,


    bei den ersten Ladevorgängen habe ich ja den Parameter auch auf Save gestellt. Dann die Datei similar_channels aus /tmp in /etc/epgload kopiert (Inhalt siehe oben post #1) . Dann anstatt Save auf Laden gestellt.
    Gerade weil die Sender im Standard Rytec File sind, frage ich ja, warum genau diese Sender bei mir nicht funktionieren, alle anderen funktionieren. Service-Reference der Kanäle habe ich oben geschrieben.


    Woran kann das liegen.

    VG, rako123

  • Wenn du ein custom Channel File generiert und kopiert hast brauchst du auch kein laden mehr bei ähnliche KanäleX(


    Wenn ihr irgendwelchen Blödsinn macht bringt es wenig zu fragen warum das nicht geht.


    Schau dir das Channels File von rytec an ob die servicerefs da drinnen sind, vorher ist es ziemlich zweckbefreit mit ähnlichen Kanälen zu laden.


    Wenn es trotz sref im Channels File nicht will brauche ich ein E2 Log von euch einem manuellen laden.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling: