Morpheus Screensaver Plugin für Enigma2

  • ich habe festgestellt, das wenn ich eingestellt habe saver bei audio und ich eine mkv abspiele, morpheus trotzdem anspringt im plugin ist aber mkv ausgeschlossen in zeile 485 und 755


    ... and not servicerefstr.endswith(".mkv")...


    wenn die mkv´s abgespielt werden beginnt JEDE mit servicerev 4097 welche ja schon für dreamnetcaststreams einbezogen wird, das beist sich irgendwie. oder denke ich falsch?

  • wäre schön, denn normalerweise schlafe ich abends mit nem stream ein und streams greifen ja nur "bei audio". deswegen habe ich ja auch die 4097 miteinbezogen


    will ich aber mal nen film schauen, muß ich jetzt jedesmal erst prüfen obs ne mkv ist -> und dann im morpheus erst deaktivieren mir und "meinen leuten" würde es schon einiges erleichtern ;)

    Code
    1. if servicerefstr.find("0:0:0:0:0:0:0:0:0:") is not -1 and not servicerefstr.startswith("4369:") and servicerefstr.startswith("4097:") and not servicerefstr.startswith("4114:") and not servicerefstr.startswith("1:0:19:") and not servicerefstr.startswith("http://") and servicerefstr.startswith("1:0:") is False and not servicerefstr.endswith(".mpg") and not servicerefstr.endswith(".vob") and not servicerefstr.endswith(".avi") and not servicerefstr.endswith(".divx") and not servicerefstr.endswith(".mv4") and not servicerefstr.endswith(".mkv") and not servicerefstr.endswith(".mp4") and not servicerefstr.endswith(".ts"):

    ps wo definiere ich die größe der uhrzeit im display? im plugin.py hab ich es nicht gefunden

  • Wie gesagt ich muss es mir erst genauer anschauen das Ausnahme if statement ist schon etwas ... lang :-)


    Bezüglich des skinnens der Uhr bin ich nicht der ideale Ansprechpartner, aber das lcd Plugin hat doch eh jede Menge Einstellmöglichkeiten wenn ich mich recht erinnere.

  • aus dem black-out thread


    Zitat

    Original von gutemine


    der sourcecode steht dir offen ...
    Und im Morpheus screensaver kannst du auch ganz schwarze pngs als screensaver anzeigen.


    das krieg ich nicht hin. habe ein komplettes schwarzes 1280*720*8 png file ausgewählt und trotzdem dunkelt es nur soweit ab, wie ich die transparenz im osd runtergeregelt habe und shift+radio funzt nicht. ich nutze die fb der 7025 für meine 8k

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von friday ()

  • Na ja man könnte in die Screensaver anspringroutine und in die beenden routine reinmachen das die transparenz auf 0 gedreht wird und nachher wieder auf den vorherigen wert.


    Vielleicht habe ich zu Weihnachten Zeit das ich dir so einen Einstellparamater ins Plugin reinmache, weil das wären nur ein Hadvoll codezeilen.

  • wohl keine zeit/lust gehabt :rolleyes:


    schöner wäre, wenn man ein mvi auswählen könnte welches als hintergrund anspringt, so wie es mechatron auch nun im dreamnetcast integriert hat dann wählt jeder sein mvi - und ich ein schwarzes - dann klappt das auch mit der transparenz

  • Mir sind die pngs aber lieber. Und nein war zu viel zu tun um mir das anzuschauen.


    Theoretisch kannst du es dir aber auch selber fixen - musst halt wenn die serviceref gleich beginnt auf die endung abprüfen, kann sein das du da groß und kleinschreibung brauchst - also *.MKV, oder ähnliches, deswegen ja das enigma2 log, weil da steht das drinnen.

  • ja entschuldige, wenn ich es könnte dann bräucht ich nicht fragen
    ich finde ja nichtmal die stellen wo es aufgerufen/gestoppt wird, geschweige denn weiß ich was mit echo eingetragen werden soll


    und das dir bei sowas trivialem fad ist kann ich gut verstehen, aber es denkt halt nicht jeder so schnell in die programmierung wie du. frag mich was über rollstühle, da kann ich mitreden


    gruß

  • Tut mir leid wenn ich mal wieder zu freundlich war - Du hast das nicht verdient. Ich hatte einen anstrengenden Tag heute, sorry.


    Also mache ich dir das mit der Transparenz als Buße halt sofort :-)


    Wie soll das funktionieren - sobald der Screensaver läuft soll das Plugin die Transparenz wegmachen damit die pngs aus dem Screensaver voll decken, und wenn der screensaver beendet wird willst du wieder die vorherige Transparenz des Skinns haben ?


    Kannst du das bevor ich es code mal von Hand durchtesten ?


    Also cat /proc/stb/video/alpha um zu sehen welche Alpha du hast.


    Dann lässt du den screensaver anspringen (geht manuell auf dem Extensions Menu auf Blau ja sofort) und machst echo 255 > /proc/stb/video/alpha und berichtest ob es dann so deckt wie du möchtest,


    Und dann beendest du den Screensaver mit exit und machst wieder echo vorherigerwert > /proc/stb/video/alpha und berichtest ob wieder alles wie vorher ist.


    Wenn das wunschegmäß klappt mache ich es in den Code rein (ich weis ja wo es genau hin muss)


    LG
    gutemine

    Einmal Rupert und Zurück

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von gutemine ()

  • Danke fürs Testen und es kann sein dass enigma2 das zuücksetzen von alleine erledigt.


    Wenn das so ist wäre das einfügen aber wirklich extrem simpel. Ich schaue mal was ich am Abend für Dich tun kann :-)

  • Probier mal das ipk aus dem Anhang, ich denke die neue Einstellung Transparenz ist selbsterklärend - und 255, also KEINE ist jetzt Default, wobei 0 auch ganz lustig ist wenn der Fisch über das TV Bild schwimmt.


    LG
    gutemine


    EDIT: Anhang wurde entfernt, weiter unten ist neuere kit.

    Einmal Rupert und Zurück

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • erst mal tnx@gutemine das du das plugin weiterentwickelst.
    wobei ich auch sagen muss das das plugin das auf meiner box ist das am stabilsten ohne updates läuft :-)



    die sache mit transparenz 0 und dem fisch bringt mich noch auf eine andere idee:
    wäre es prinzipiell auch möglich als screensaver einfach das tv-bild zu nehmen und dieses alle 30 sekunden um einen pixel von der normalen position weg und 30 sekunden danach wieder zurück zu verschieben? (richtung zufällig, also mal oben, mal unten, mal links oben,...).


    das würde doch den "screensaveranforderungen" denke ich genügen (wenn 1 dafür nicht reicht dann halt 10).
    ich glaube panasonic plasmas machen oder machten das doch so um einbrennen zu verhindern, wenn ich mich nicht irre.

  • na ja theoretisch geht das schon, aber da müsste man das tv bild kleiner machen damit man es verschieben kann, und bei großflächegen Sachen funktioniert es nicht egal wie viele <<pixel du nimms, da ist ein grauschleier wenn du mit geringen Trnsparenzwerten arbeitest genauso gut. Und wirklich aufregend wäre ein PIP TV der über den Bildschirm wandert auch nicht, wobei du es gerne entsprechend anpassen kannst, das /proc interface steht dir ja offen und aus der Transaprenz siehst du ja das es nur 3 Zeile sind da was reinzuschreiben.


    Aber ins Morpheus sind schon zu viele Sachen reingemacht worden, selber mache ich da wohl nur mehr bugfixes und kleingkeiten, weil eigentlich müsste man es Neuschreiben und ich bin schon froh wenn es stabil läuft.

  • gemeint war auch etwas anderes. nicht ein bild drüberlegen sondern das tv bild selbst als screensaver verwenden indem man es einfach nicht pixelgenau auf der selben stelle lässt.


    wenn es bei der dream eine art x/y offset für das ausgegebene bild gibt der im betrieb geändert werden kann könnte man jede minute einfach ein pixel in irgeneine richtung gehen, und in der nächsten wieder zurück. somit wäre sichergestellt das kein pixel, selbst bei standbild, zu lange hellgeschaltet bleibt :-)


    der effekt sollte umerklich sein und auch bei dauereingeblendeten hellen senderlogos wirken.
    aber du hast recht, das geht irgendwie in eine andere richtung als der screensaver.

  • Ich habe das schon verstanden und auch so beantwortet.


    WENN du das TV Bild kleiner machst (geht über echos ins /proc interafce) dann kannst du es auch am TV verschieben. ABER wenn du da nur ein paar Pixel wegnimmst um dann auch nur ein paar Pixel verschieben zu können DANN wird das bild total unscharf weil extrapoliert werden muss. Insofern geht das nicht genauso wie der TV das macht, und wie schon gesagt es gibt Fälle wo das nichts helfen würde womit es falsche Sicherheit vermittelt. Letztendlich ist das meistens ja eine Einschlaf oder Weggehsicherung womit ein dummes schwarzes PNG und schewarzes OLED so wie es jetzt ist immer noch am besten ist.


    Der springende Pinguin ist da nur zur Unterhaltung und damit du weist der Screensaver läuft und nicht glaubst Bx ist schon aus.

  • Zitat

    # thank god it's friday

    :D
    leider noch nicht ganz. denn wenn morpheus anspringt, habe ich immernoch meine vorherige transparenz wenn ich dann über telnet echo 255 > /proc/stb/video/alpha mache, erst dann ist es auch 255=deckend aber was anderes, wenn ich morpheus uber laufendes tv von hand aufrufe, dann ist auch der ton weg :cursing:

  • Danke fürs Testen - und fein das du das Kommentar entdeckt hast :-)


    Das ist aber seltsam, weil im prinzip macht der code auch nichts anderes wie das echo.


    Ich habe das jetzt extra mit dem Glasline skinn ausprobiert der reichlich Transaprenz hat und da schaut NICHTs durch sobald der Screensaver anspringt wenn Trasnparenz auf 255 steht.


    Und natürlich wird bei TV bild auch der Ton weggemacht (meistens steht das ja eh wegen Timeshift Pause oder Ende des Films, nur bei Adio Files und Radio wird nicht gemutet weil da soll ja die Musik weiterspielen.


    Soll ich das einstellbar machen (Mute when TV Screensaver oder so ähnlich ?) damit man bei laufendem TV Ton einschalfen kann und der TV geschont wiird ?


    LG
    gutemine

  • ja danke, denn abundzu schlafe ich wirklich gern mit tv ein (samstags wenn die mixe auf deluxe musik läuft) da will ich dann natürlich nur den ton haben.


    aber warum funzt das bei mir nicht mit der transparenz? kann das vielleicht mal wer anderes testen?

  • welchen Skin verwendest du und was hast du bei den AV Einstellungen als Transparenz eingestellt, vieleicht kann ich das reproduzieren.


    Und wie gesagt dein Wunsch was das mute angeht ist schon umgesetzt - nur testen musst du es noch :-)

  • Da fehlt mir der inf_ds_digital.ttf Font und die Renderer, insofern ist da nicht so einfach mit ausprobieren.


    Kannst du es bitte mal mit einem der Skins von OoZooN's Feed probieren ?


    Du darfst nicht vergessen das wenn du hören Z Wert im Skinn hast dieser noch vor dem Screensaver landen kann, das hat dann aber nichts mit der Transparenz zu tun.

  • sorry wegen dem skin
    habs grad mit dem brushed alu hd von kerni und sogar dem default skin probiert = ergebnis ist das gleiche


    ich hab mal als hintergrund rot gewählt um fehler mit meinem schwarzem png auszuschließen (wobei es da eigentlich keine geben sollte), es wird zwar rot, jedoch nur in der tranzparenz die man als gui-deckkraft eingestellt hat. nicht deckend!


    vielleicht hat mechatron deswegen darauf verzichtet und lieber die möglichkeit von eigenen .mvi´s eingebaut im dreamnetcast

  • nein weil mvi files werden in den Videobuffer geschrieben da ist die Transparenz des Framebuffers egal und der ist immer davor. Da muss man dann alles geslinnte abdrehen/zumachen damit es voll deckt,


    Also ich komme einfach nicht drauf was da falschläuft. Ich teste zwar nicht mit einem schwarzen PNG sondern mit den Farben schwarz, aber da ist sobald ich 255 bei Transparenz habe absolut nichts zu sehen am TV, und bei z.B. 100 siehst du alles durch. Und da ist auch egal welche Transparenz sonst in den AV Einstellungen eingestellt ist.


    Und wenn ich z.B. Fisch mit Riff png nehme ist das auch absolut deckend wenn die Transparenz auf 255 steht.


    Kann das noch wer anderer Testen ?


    Und kannst du bitte nachsehen ob wenigstens der Wert reingechrieben wird wenn der Screensaver läuft:


    cat /proc/stb/video/alpha


    Und du verwendest auch keine skind default/user xml wo Morpheus gesckinned ist mit transparent=0 oder ähnlichem ?


    PS: geht wenigstens das Muten beim TV jetzt so abdrehen wie du möchtest ?


    LG
    gutemine

    Einmal Rupert und Zurück

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • ja herrschafts zeiten :cursing:


    nein der wert wird nicht geschrieben wenn morpheus läuft, es bleibt bei meiner durch das gui definierten transparenz
    ich habe das gefühl bei meinem dmm-exp stimmt etwas gewaltig nichtmehr


    als ich die settings datei kontrollierte fand sich auch kein wert für die transparenz. trotz mehrfachem gui start + reboot. irgendwann tauchte der wert auf mit 255. daraufhin nochmal ein reboot im telnet und der wert ist immernoch da. ABER es ändert nix am verhalten. es dimmt nur soweit, wie ich in der gui-deckkraft eingestellt habe.


    ps: mute/unmute beim tv geht jetzt prima, danke hierfür

  • 255 ist der Default Wert und die werden nie in die settings geschrieben um Platz zu sparen. Wenn Du 254 nehmen würdest stünde es nach enigma2 restart drinnen.


    Irgendwie ist das aber seltsam. wobei mit aktuellem Experimental habe ich es nicht ausprobiert, nur das letzte OoZooN Experimental image inklusive der Aktualisierungen von gestern, das sollte aber keinen Unterschied machen.


    Wobei du schon das komische zurückstellen des alphas hattest was er bei mir nicht tut, es kann also sein dass dies auch wärend der screensaver läuft den Wert sofort wieder auf das ändern was für die GUI eingestellt ist.


    NUR das müsste dann irgendein Plugin oder ein Renderer sein des skinns der das tut, dann kann ich das aber nicht ändern.


    Wenn du Lust hast kannst du ja mit BA mal ein OoZoon ohne was dazu zu installieren ausprobieren und nur mit Morpheus - vieleicht kommen wir dann ja drauf ob es am Image oder einem anderen Plugin liegt.


    Weil den code der es reinschreibt hast du ja gefunden, und der tut auch sonst würde es crashen.


    Und bei deinem mkf Abspielproblem, hast du jetzt in telnet nachgesehen ob die als *.mkv oder *.MKV angezeigt werden ?


    LG
    gutemine

  • Ja Bitte, weil wie du richtig erkannt hast wird geschaut wie die serviceref anfängt und wie sie aufhört - wenn beides stimmt sollte Morpheus eigentlich erkennen das er nicht schlafen gehen soll.

    Einmal Rupert und Zurück

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • Hallo Gutemine,


    ich habe das aktuelle OE2 und u.a. das Plugin Morpheus Screensaver installiert.
    Nach dem installieren bekam ich immer sofort einen Greenscreen.
    Dieses Problem wurde bereits hier im IHAD Forum angesprochen und eine veränderte "Plugin-py" zur Verfügung gestellt.
    [edit by Mod.] bitte keine offenen Links, danke.


    Wenn man diese modifizierte Plugin.py manuell installiert läuft auch erstmal alles soweit, bis auf die Wiedergabe von Videos.
    Dort erhalte ich wieder einen Greenscreen mit dem Hinweis auf eine fehlende oder falsch definierte Variable.


    gutemine :
    Könntest Du Dir das mal anschauen?


    Danke und Gruß

  • Das mit dem gs hatte ich nun auch gefixt.
    Hatte einfach "Infobar" statt,dem richtigen,"InfoBar".
    So wie morpheus ansich den infobar krams patched it in dem neuen oe2 nicht mehr möglich,als hatte ich das mit hilfe von dr best geändert.
    Problem ist jetzt nur das es jetzt zwar nicht mehr crashed und auch der counter noch läuft,aber das nach der eingestellten zeit,kein screensaver mehr kommt.
    Wie auch immer...Hier... :)