[eingestellt] Barry Allen 6.5 Released kit & Support Thread

  • Hier ist das Changelog für die Version 6.5.21 von Barry Allen.


    * Das ist die LETZTE releaste Version für OE 1.6 in der alle bekannten Bugs aus den früheren Versionen gefixed sein sollten, womit alle früheren Versionen NICHT mehr supported sind!


    * auch diese Version wird im Herbst 2012 die Arbeit einstellen wenn mein OE 1.6 Support endet.


    * im Plugin ist jetzt eine Bootimage Auswahl gleich auf der Hauptseite. Einfach die < > Tasten neben der 0 benutzen (und mit 0 wählt man das Flash Image)


    * mdev basierende images sollte jetzt HOFFENTLICH ENDLICH auch wieder funktionieren


    * die fstab in den BA Images wird jetzt WIEDER angepasst


    * die 7025 und das BA WebIF sollten jetzt wieder funktionieren, genauso wie WW


    * Auch der Wally West Support ist released. Infos dazu und den WW kit findet Ihr im WW Thread.


    * Diese Version läuft NUR mit dem aktuellen Original Loader #84 von DMM (bei der 7025 kann man es daher NUR mehr mit Loader 83 und dem Schummel ipk für Loder 84 benutzen das auch hier anhängt). Ausnahme ist die dm7020HD, da MUSS jetzt bereits Loader #86 auf der Box sein


    * BA 6.5 unterstützt KEINE Images mehr die den Loop device Treiber nicht im Kernel haben und ohne so ein Image im Flash hat wird der BA 6.5 kit sogar die installation verweigern.


    * der Bootmanager hat jetzt eine Option die mit einen Balken anzeigt wie lange man noch Zeit hat ein Image zum booten auszuwählen. Das Anzeige des Balken kann man aber in den BA boot Optionen im Plugin auch wieder abdrehen.


    * dort kann man jetzt auch zwischen mvi bootlogos und Bildern (bmp und jpg aber nur im Format 600x576 mit 24 Bit Farben sind jetzt unterstützt) als Hintergrund für den Bootmanager umschalten.


    * der Bootmanager kann jetzt auch wieder die Dreambox in den Flashmodus zwingen indem /boot gelöscht wird - einfach TEXT Taste auf der Fernbedienung drücken.


    * der /MB_Images link wird NICHT mehr verwendet, sondern es wird einfach /media/hdd/backup benutzt und NUR falls es dieses nicht gibt auch /media/ba/backup benutzt.


    * und die Anleitung von romeo-golf für Barry Allen 6 gibt es hier:


    Barry Allen Anleitung


    LG
    gutemine

  • * der Kit ist seit Herbst 2012 abgelaufen und wird nicht mehr funktionieren.


    * EIGENTLICH sollte man das Problem mit einem aktuellen Image im Flash ja gar nicht haben, aber falls man den loop device Treiber deinstallieren muss, geht das über die Softwareverwaltung oder in telnet im Flashimage:


    ipkg remove kernel-module-loop


    * Beim aktuellen BA wird den loop device Treiber NICHT mehr nachladen, da hilft dann auch kein Nachinstallieren mehr - also aktualisiert besser Euer Flashimage, weil der aktuelle BA kit ist für Images >= den 3.2.2 release Images gedacht wo der loop device Treiber fix im Kernel ist.


    * auf der 7020HD ist NUR mehr Loader 86 unterstützt - falls Ihr den noch nicht auf dem Feed habt müsst Ihr das nfi einzeln nachinstallieren.


    * wenn man ein Image mit aktuellem Kernel im Flash hat werden ältere Images evt. vom BA device evt. nicht mehr booten - falls diese schon einen entsprechenden Update am Feed haben kann man vom Flash booten und diese in der chroot updaten, dann sollten sie wieder booten:


    ba.sh chroot namedesimages
    ipkg update
    ipkg upgrade
    exit
    ba.sh boot namedesimages now


    * Wenn mehrere Devices den Label ba haben, wird dies bei der Installation versucht zu bereinigen. TROTZDEM sollte man nach fehlgeschlagenen Installationen oder solchen auf unerwünschten devices ein ipkg remove enigma2-plugin-extensions-barryallen machen um diese SAUBER aufzuräumen. .


    * beim Filesystemcheck mit bainit 90 sollte man nicht das telnet vom DCC verwenden, sondern mit Putty oder ähnlichem arbeiten da DCC auch eine FTP Verbindung aufbaut die wiederum das umounten für den Filesystemcheck verhindert.


    * Wenn ein initramfs Kernel vorhanden ist wird WW jetzt auch automatisch Label mounten verwenden, schon weil das stabiler ist wenn man devices an und absteckt.


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 73 Mal editiert, zuletzt von gutemine ()

  • Because of the below Thread where somebody tried to cheat support for a Cloebox with a Clonebox Loader 84 and a Patched Image that we don't support here and a patched BA kit which is called 6.* and a SIM Number I have to give you my good advice once more:


    I was so friendly to check the content of this patched BA Version.


    It is simply an old bainit shellscript from 6.0 and an old bootmanager 5.2.12 and bunch of old binaries binary which are regarded as 'safe' - from whom ?


    Unfortunately 4 of these binaries speak perfect Spanish and contain also the clone protection which is operating in a very discrete mode and practices his Spanish with these boxes on a regular basis.


    Every time your are booting your box with it, unpack an image or are creating a backup image including your hacked bootloader they do their job perfectly when they are called.


    And gutemine warnes about this misuse now since almost 2 years.


    Depending on the quality of your Flash Chips and how often you boot or backup your box with such a BA Version (no matter if patched or an old original one regarded as safe) it could now be that the point of end-of-live of your box is now pretty close or already reached.


    Hence I can only repeat my good advice:

    Stop using BA on Cloneboxes or you simple have to live with the consequenzes - earlier or later!


    And don't complain here or try to discuss this matter, as this would be the wrong place and the wrong person - complain wherever you got these kits from on what these people have done to your Clonebox by ignoring good advice!


    Original Dreamboxes are perfectly save no matter which BA Version you are using, but off course it is always good advice to use the latest BA as only this will be fully supported in case of troubles and they only accept the latest original Bootloaders from DMM as the BA Release Notes state.


    And don't feel too save with other Multiboot tools either, as they also use some of gutemine's helpfull binaries designed for original Dreamboxes.


    Ciao
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 24 Mal editiert, zuletzt von gutemine ()

  • BA 6.0 hat im ipk als abhängigkeit das der Loader mindestens Version 84 haben soll. Der aktuelle Loader der 7025 ist aber 83, womit eigentlich die 7025 nur mehr BA 5.* verwenden kann/soll.


    ABER nachdem die loader Version auf der 7025 in aktuellen images sowieso NICHT in der opkg status database steht und DMM scheinbar nicht bereit ist das zu fixen sollte man das sowieso reparieren damit man wenn man ein Plugin mit Loader Anhängigkeit installiert dieser nicht nachinstalliert wird obwohl eh schon vorhanden, weil das meistens nicht gut geht und man dann mit DreamUP seriell flashen muss.


    Dafür ein Auszug aus dem Dumbo Wiki:


    Paketverwaltung austricksen
    Wir gaukeln jetzt der Paketverwaltung vor, dass der benötige Second Stage Loader schon installiert ist.


    Zuerst erstellen wir die Datei dreambox-secondstage.list mit folgendem Befehl.


    touch /usr/lib/opkg/info/dreambox-secondstage.list


    Nun müsst ihr noch die Datei /usr/lib/opkg/status editieren und am Ende folgenden Eintrag machen. Benutzt dazu bitte einen unixkonformen Editor (z.B. Notepad++).
    Wobei ich den vi Editor direkt auf der box verwende.


    Package: dreambox-secondstage
    Version: 83-r0a
    Depends: dreambox-bootlogo (>= 7.0)
    Provides:
    Status: install ok installed
    Architecture: dm7025
    Installed-Time: 1315676295
    Auto-Installed: yes


    Na ja und im Prinzip kann man hier auch lügen und einfach 84 als Version hinschreiben, dann installiert auch BA 6.0 und sollte auch wie gewohnt funktionieren.


    Einfacher ist aber du verwendest das dummy loader ipk aus meiner nächsten Reply :-D


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von gutemine ()

  • Was solls, im Anhang ist ein dummy SSl 84 Paket für die 7025 damit das Gejammere endlich aufhört.


    Im Prinzip ist das natürlich kein echter loader 84 sonder indem man das ipk installiert repariert man einfach den ssl Eintrag in der opkg status database.


    Wenn DMM nicht bereit ist es zu fixen habe ich auch kein schlechtes Gewissen dabei sowas zur Verfügung zu stellen !


    Also nichts mir herumeditieren, einfach das ipk aus dem Ahang VOR dem BA 6.0 kit installieren und schon sollte Ruhe sein mit allen Plugins die Loader 84 als Voraussetzung haben.


    Bitte auf der 7025 testen und berichten ob es funktioniert. Sollte DMM je einen loader 84 für die 7025 rausbringen (was wahrscheinlich nicht der Fall sein wird weil die alten 7025 ja keinen security chip haben) können sie den dann gerne 84a taufen. Indem sie es monatelang nicht gefixed haben denke ich haben wir auch ein moralisches Recht zur Selbsthilfe zu greifen.


    Insofern kann man das ipk sogar auf einen Software Update feed machen damit es automatisch installiert wird sobald die Abhängigkeiten anderer pakete es verlangen, aber das muss OoZooN entscheiden.


    LG
    gutemine


    EDIT: Anhang wurde entfernt, weil der ist jetzt auf der ersten Seite

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • An Weihnachten so ein "Lügen"-Paket ... ts ts ts. Aber na ja, was soll's. :D


    Fragen: Welche Vorteile bringt mir dieses Verbiege-Update ?
    Welche Updates außer BA 6 fragen sonst noch nach dem SSL v84 ?



    Meine 7025 dürfte eine der älteren Bauart sein, nix mit "+" und so. Ich hab seit Monaten das Problem, dass das Hochfahren nach dm Einschalten, beim Neustart usw. beim booten des (Oozoon-) Image im Flash relativ schnell geht, bei über BA gebootete Images ( zur Zeit unter anderem das aktuelle OozZoon, Release + Exp.) es aber immer mehrere Minuten (5 - 7) dauert, bis n Bild da ist.


    Und wenn ich über die Fernbed. einen "Neustart" anwähle, bleibt die Box manchmal sogar komplett hängen, dann kommt nicht mal mehr der erste Begrüßungsbildschirm. Dann bleibt nur noch Hardware ausschalten und neu starten.


    Besteht Hoffnung, dass sich mit BA 6 daran etwas ändert ? Sonst lass ich das lieber sein. :-)

  • Im Prinzip habe ich schon Skrupel ein Mogelpaket zu veröffentlichen, ABER ich habe den Bug vor Monaten reportet, der ist auch extrem einfach zu fixen (ist eh nur ein Tippfehler von DMM im Build file als sie die 7020hd eingechecked haben) und trotz nachfassen hat DMM es nicht für wert befunden es zu fixen


    Ich habe also jetzt eben kein schlechtes Gewissen mehr es auf diese weise in Selbsthilfe zu 'lösen', weil mir tun die 7025 Besitzer einfach leid da es meine erste enigma2 box war die lange Ihre Dienste getan hat. Und mit Editor in der opkg status Database herum zu fuhrwerken ist halt nicht jedermanns Sache.


    Ich weis nicht welche Plugins alle Loader 84 als Prerequisites haben, meine wie dFlash, Dumbo, BA haben es eben schon, auch um ein bisschen Klone zu ärgern die mit Ihren 83F oder wie sie alle heissen herumfuhrwerken müssen. Ich weis natürlich dass dies leicht auszuhebeln ist indem man in der opkg status database lügt, aber was solls, auch Zeichen sind dazu da um gesetzt zu werden.


    Und nein das von Dir beschriebene Verhalten hast du meistens nur wenn das device kein DMA kann, oder synchron gemountet wird, oder im Kompatibilitätsmodus (der nötig ist weil die 7025 uralten CF Reader verbaut hat) nicht ordentlich läuft und immer wieder IO retries verursacht (das sieht man mit dmesg in telnet was da abgeht).


    Insofern würde ich andere CF Probieren oder wenigstens die vorhandene mal sicherheitshalbe mit dem HP USB Bootdisk Tool an einem PC Komplett neu formatieren und BA neu drauf installieren, weil das hat nichts mit BA zu tun und wird sich sonst auch mit BA 6.0 nicht ändern.


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Hm ... das gibt neue Fragen, leider wohl etwas OT.


    Was bitte meinst du mit "synchron gemountet wird" ? Kann ich das beeinflussen ?
    Und wie bzw. woran kann ich sehen, ob ein Device DMA-fähig ist ?
    Welches Device käme denn als Verursacher in Frage ? Prinzipiell vermutlich jedes vorhandene, schätze ich mal ?!
    Also die HDD ? Und der externe NAS ? Und auch die 8k, die wird bei mir auch in der fstab gemountet ?


    Eine andere, nagelneue 8 GB CF von Sandisk, hatte ich vor Monaten wegen des Problems schon mal probiert, natürlich vorher am PC neu formatiert ... es hat leider nichts genutzt. :-( Und ich hatte dafür doch sogar extra eine "schnelle" CF gekauft.

  • Extra schnelle CF bringt eigentlich .... nichts.


    Die Dreambox ist keine Kamera wo man möglichst schnell die Bilder drauf schreiben will.


    Und der CF leser der 7025 ist uralt, genau mit so schnellern neuen CF Karten die es zu seiner Zeit gar nicht gab kann es Probleme geben.


    Insofern sind alte, billige CF karten die auch nicht zu gross sind (kostet nur bootspeed sowas großes zu mounten und das eh schon knappe Memory der 70205 den filesystemchache dafür zu halten). Ideal sind 512MB-2GB, alles drüber ist Verschwendung


    DMA kann man mit hdparm checken, mount optionen mit mount


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Ja Danke!


    Hab das damals auch noch bei DMM angestossen, weil ich bei einem Paket (weiis jetzt nicht mehr welches) dieses Problem hatte..
    zu hdparm würde mich interessieren, wie ich da DMA aktivieren kann ? hdparm /dev/hdc -d 1 oder wie ?
    bei meinen beiden Devices HDD und CF steht use DMA auf 0 (off). kann ich das auch im BIOS einstellen ?


    Danke


    Big11

  • Ebenfalls Besten Dank!


    Ich hab nun die mounts für NAS und DM8000 aus der fstab raus genommen, nun muss halt automount dafür herhalten.
    Und siehe da, nach einem Neustart ist die Box in 2 Minuten wieder zurück. So lasse ich das mal, da kann ich mit leben.
    Danke nochmal.

  • Diese Frage hatte ich in anderem Zusammenhang wohl schon einmal gestellt. Da sie unbeantwortet blieb, das Ganze nochmals unter neuen Bedingnugen.


    Kann es sein, dass die Imageaktualisierungen unter Barry Allen nicht vollständig funktionieren? Definitiv kann ich sagen, dass etwa das iCVS-Image vom August sich nicht hat vollständig aktualisieren lassen. Beispielsweise funktionerte weder die Aktualisierung des SSL #83 -> #84 noch wurden die für die blind scan Option nötigen Treiber auf den neuesten Stand gebracht. Das Image (OoZooN) im Flash der Box wurde stets vollständig durch die Updates aktualisiert.


    All dies schließe ich aus der Tatsache, dass eine Neuinstallation unter Barry Allen des iCVS vom November diese Probleme beseitigte.


    Bleibt die Frage: Liegt's an dem verwendeten Image oder an Barry Allen? Oder verstehe ich mal wieder nichts richtig. ?(


    viele Grüße
    wysiwyg

  • Das liegt daran der der neue loader neue bootlogos braucht (weil dort ein neues bootlogo.elf drinnen ist) und weil in BA images /boot als mount point auskommentiert ist womit das mit dem normalen Softwareupdate nicht geht..


    ---> 3x drafst du raten wofür im BA es einen eigenen Softwareupdate gibt wo das temporär rückgängig gemacht wird - und ja das steht in der BA doku :-)


    Und ja das steht auch auf der ToDo Liste es auf einen bind mount abzuändern wie im LowfAT

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Das ist mir schon soweit klar. Selbstverständlich hatte ich zuvor mittels ba.sh chroot <Image> und ipkg update && ipgk upgrade vergeblich versucht, das Image auf den neuesten Stand zu bringen. Beispielsweise wurden weder der Loader noch die Treiber, welche wohl die uncable Option bereitstellen, aktualisiert. Wie ich an anderer Stelle schrieb, half erst eine Neuinstallation des iCVS vom November.


    Also verstehe ich das Ganze wohl noch immer nicht richtig ?(


    viele Grüße
    wysiwyg

  • Bitte direkte Antworten nicht wiederholen, edit & danke Bukowsky
    Getreu deine Anweisung befolgend, habe ich also auch über das BA-Plugin unter Optionen-Allgemein -> Enigma2 Software Aktualisierung dies veranlasst. Das Ergebnis ist leider dasselbe: Der SSL wird nicht aktualisiert und Suchart unicable geht immer noch nicht.


    Gibt es überhaupt einen Unterschied zwischen den oben genannten Telnet-Befehlen und dieser Menüoption?


    viele Grüße
    wyswiyg

  • Die Logdateien habe ich (fast schon aus Verzweiflung) einmal für upgrade && update und einzeln für upgrade und update erstellt. Ich kann daran nichts Besonderes erkennen, außer dass er dein dFlash nicht installieren kann, weil ja nur der SSL #83 vorhanden ist. Aber du bist ja der Fachmann. ;)


    Dass nur so wenige Aktualisierungen in den Logdateien auftauchen, ist dem Umstand zu verdanken, dass bei dem ersten upgrade && update die meisten Aktualisierungen wohl erfolgreich waren.


    viele Grüße
    wysiwyg


    Logdatei.txt -> Ausgabe von ipkg ugrade && ipkg upgrade
    LogdateiUpdat.txt -> Ausgabe von ipgk update
    LogdateiUpgrade.txt -> Ausgabe von ipkg upgrade

    Dateien

    • Logdatei.txt

      (697 Byte, 10 Mal heruntergeladen, zuletzt: )
    • LogUpdate.txt

      (2,08 kB, 14 Mal heruntergeladen, zuletzt: )
    • LogUpgrade.txt

      (697 Byte, 7 Mal heruntergeladen, zuletzt: )
  • Ich wollte aber das log von ba.sh opkg update haben :-)


    Und den Menupunkt get latest loader im BA Plugin hast du auch schon entdeckt ?


    PS: Könnte einer der 7025 Besitzer mir den output posten von:


    ls -alh /dev/rfmod0

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • Wo bitte finde ich denn diese Option get latest loader ?( Nein, die ist mir bis heute noch nicht untergekommen.
    Leider kann ich im Moment keine Logdatei erstellen, da eine Aufnahme läuft. Ich will nicht riskieren, dass diese abbricht.


    viele Grüße
    wysiwyg

  • In der BA doku sollte das auch stehen, oder ba.sh get_latest_loader in telnet reicht auch ...


    Und nochmals als PS: Könnte einer der 7025 Besitzer mir den output posten von:


    ls -alh /dev/rfmod0

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Da sollte wohl die Anleitung einmal ergänzt werden.


    Aber geht get_latest_loader ohnehin nur, wenn vom Flash gebootet wurde? Im Flash-Image ist aber bereits der neue Loader durch die Aktualisierungen schon auf dem neuesten Stand.


    Hier nun die Logdatei von opgk udate. Hierin ist erstmalig zu sehen, dass tatsächlich /boot gemountet wird. Aber der Loader ist wohl nicht aktualisiert worden. Dies zeigt sich auch nach einem Neustart und Aufruf der Info im blue panel.


    Die Option blindscan in der Kanalsuche funktioniert nach wie vor ebenfalls nicht.


    viele Grüße
    wysiwyg

    Dateien

    • Logdatei.txt

      (3,27 kB, 13 Mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von wysiwyg ()

  • Du weist aber schon das auf dem iCVS Image vom Marz Feed gar kein ssl 84 zu finden ist und man daher auch nicht ohne Neuflashen eines aktuellen iCVS Images aktualisieren kann - und das gilt im BA genauso wie im Flash.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von gutemine ()

  • Ja, jetzt weiß ich's. Da steht tatsächlich doch im Log, dass ein uralter Feed verwendet wird.


    Wenn ich mich recht entsinne, habe ich jedoch das OoZooN-Image aus dieser Zeit doch auch nur durch Aktualisierungen auf den heutigen Stand gebracht. Aber wenn du es schreibst, wird es wohl doch nicht so sein.


    Verstehe ich dich recht, dass ich alle Images neu flashen muss, weil sie über Aktualisierungen gar nicht auf den neuesten Stand zu bringen sind? Jedenfalls muss dem bei den iCVS-Images so sein, da diese ja auf alte Feeds zurückgreifen. D.h: Die gesamten aufwendigen Konfigurationen sind also alle zum Teufel und ich darf alles nochmals neu aufsetzen. Schöne Sch.. ;(


    viele Grüße
    wysiwyg

  • Mit dem ba.sh get_latest_loader kannst du es dem image zwar trotzdem von OoZooN's Feed reinwürgen, aber gescheit ist das nicht weil Treiber und enigma2 dann trotzdem alt bleiben.


    Und du verletzt damit die BA Regeln das man keine alten mit neuen Images mischen soll - was auch in der Doku steht.


    Aktuelles iCVS, Merlin, NN2, etc mit aktuellem Loader 84 gehen alle wunderbar mit aktuellem OoZooN im Flash mit BA 6.0.* booten - alles andere wird nicht supportet und funktioniert auch nicht richtig.


    Und ich kann nichts dafür das OoZoN ein paar Jahre Erfahrung damit hat Softwareupdates für Images zu machen und deswegen seine Images oft erschreckend lange aktualisierbar sind :-)


    Nicht umsonst benutze ich OoZoon Images selbst im Flash und empfehle diese auch als Grundlage fürs Multibooten um eben ums echte Neuflashen so lange wie möglich herum zu kommen.


    Ausserdem war und ist OoZooN auch immer sehr entgegenkommend was Multiboot spezifische Anforderungen an die images angeht und hat als erster die USB Treiber fix in den Kernel gemacht - was in den DMM standard übernommen wurde, FAT wieder im OE 1.6 in den Kernel gemacht was in den DMM Standard übernommen wurde, und auch die initramfs Patches eingebaut was aus verständlichen Gründen NICHT in den DMM Standard kommen wird.


    LG
    gutemine

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • Bei aller Enttäuschung vergaß ich, mich bei dir für deine Hilfe zu bedanken. Daher jetzt ganz laut HERZLICHEN DANK!


    Im Flash habe ich schon lange das Image von OoZooN, deine Hinweise waren ja auch deutlich genug. Wenn ich nun schon alles neu machen muss, dann werde ich wohl auch mein Gebrauchsimage (das der Rest der Familie nutzt) auch auf OoZooN aufbauen. Das PiPZap gibt's ja mittlerweile als Plugin und das Blue Panel sollte ja auch auf OoZoon's Image problemlos laufen. Die übrigen von dir genannten Images nutze ich ohnehin eher zum Spielen als zum Fernsehen.


    Nachmals vielen Dank für deine Hilfe und ..


    viele Grüße
    wysiwyg

  • Du musst nicht 'alles' neu machen, einfach aktuelles iCVS auch noch aufs BA device packen, vorher settings sichern, nachher restoren und den rest kann man auch ganz leicht zwischen den /media/ba/ba/imagadirectories kopieren.


    BA ist ja dafür da schnell mal images aufzusetzen und nicht um für die Ewigkeit immer das gleiche zu haben

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Vielen Dank für deine Tipps. So kann ich wenigstens meine Konfigurationsdateien für die Quickbuttons, die ich teilweise aufwendig von Hand kodiert habe, retten. Aber ich fürchte, da wartet dennoch eine ganz schöne Menge Arbeit auf mich. Einige der Plugins, Tools, .. die ich nutze, sind leider mittlerweile von den Feeds längst verschwunden. Seit ich die Anleitung geschrieben habe, weiß ich natürlich, wie man diese hätte von den Feeds laden und sich abspeichern können. Leider habe ich nicht alle auf diese Weise sichern könnnen. Jetzt heißt's erst einmal suchen .. ;(


    Aber das Rezept ist jetzt klar: Alle Plugins werden abgespeichert und alle Einstellungen protokolliert. Damit verbleibt auch in Zukunft in solchen Fällen schon noch viel Arbeit. Aber das leidige Suchen entfällt wenigstens.


    viele Grüße
    wysiwyg

  • Na ja das ist ja die Idee vom BA das man das alte Image behalten kann selbst wenn es nicht mehr bootet, dann hat man zwar einiges zum kopieren aber alles ist noch da - ist ja nicht so wie im Flash wo man immer nur eines haben kann.


    Moderne Vielweiberei sozusagen ....


    Wenn man faul ist schreibt man sich das kopieren der wichtigsten Dateien sogar in ein bapostinst script dann passiert das bereits beim Imageauspacken automatisch, so wandern meine auto.network, etc immer gleich mit. Ich kann damit ein image in <5 min komplett einrichten.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Bitte direkte Antworten nicht wiederholen, edit & danke Bukowsky
    Daran habe ich auch schon gedacht, als ich gestern mich nochmals mittels Anleitung in dein BA vertiefte. Ob ich nun das Ganze in einer Textdatei dokumentiere oder gleich ein entsprechendes Script verfasse ..


    Leider hat die Sache für mich einen gewaltigen Haken: Mir ist Linux und die zugehörige Scriptsprache (noch) fremd. So ist selbst mit deiner Vorlage im BA-Verzeichnis für mich (noch) kein einfacher Einstieg möglich, weil ich das Ganze einfach (noch) nicht überblicke: Wo ist was zu finden? Wie musss dieses wie jenes kodieren? .. Wenn das Ganze in Windoofs wäre, ich hätte längst ein VBA-Script, das mir dies alles erledigte.


    Aber vielleicht sollte ich mich doch nochmals intensiver mit dem Settings Manager von JackDaniel auseinandersetzen? Leider ist die Unterstützung von der Seite nicht so toll. All meine Anfragen und Vorschläge verliefen bisher mehr oder weniger im Sand. Da wäre es vielleicht doch ratsamer, alles gleich selbst mittels bapostinst zu erledigen.


    Ja, wenn ich so viel Zeit hätte, wie Freude an dem Ganzen ..


    viele Grüße
    wysiwyg

  • Und nochmals als PS: Könnte einer der 7025 Besitzer mir den output posten von:


    ls -alh /dev/rfmod0


    Code
    1. crw------- 1 root root 249, 0 Jan 1 1970 /dev/rfmod0
  • Hi,


    funktioniert dein Plugin auch in Verbindung mit einem SATA Flash Modul ohne Probleme?

  • Ja natürlich, bei chroot booten ist es egal was du nimmst, da geht auch z.B. der vordere USB bei der 7020HD und eben auch interne und externe SATA, egal ob stick, ssd oder normale Harddisk


    Mit kernel command line umsetzen geht auch Dumbo drauf, LowFAT geht aber NICHT von SSD

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von gutemine ()

  • Danke,


    dann werde ich mir morgen mal ein Delock Sata Flash Modul besorgen.


    Muss ich vor dem Einbau noch etwas konfigurieren, oder auf etwas besonderes achten?


    Ich nehme an das ich noch den Eintrag /dev/sdb1 /media/ssd auto defaults 0 0 hinzu fügen muss?


    Meine fstab sieht imo so aus:

  • nein, bei BA musst du selbst gar nichts mounten, BA kümmert sich um sein bootdevice selber. Einfach richtig anschließen an den Anschluss rechts oben neben der Powersupply so das der stick als /dev/sdb erkannt wird, den Rest macht BA beim installieren

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Ok, dann schau ich mal morgen weiter wenn ich das Teil eingebaut habe, ggf werde ich dann eventuell einen neuen Thread zum Thema Flash Modul eröffnen. ;)


    Danke dir :thumbup:


    CU

  • In der 8000 ist das eine geile Sache, die box bootet damit ohne änderung an image mit Dumbo bereits in knapp 1 Minute, also praktisch genauso schnell wie die 7020HD - ich muss mir mal den Spass machen den Delock in die 7020HD zu machen, aber im Moment habe ich noch jede Menge andere Sorgen mit der 7020HD bis wieder alles so geht wie auf den anderen Boxen.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Den Delock wollte ich mir auch holen aber die Preise sind gestiegen so dass der 2 GB um die 60 Euro kostet und der 1 GB so 40 Euro ! Den mit meiner SD Karte habe ich immerwieder probleme das irgendwas nicht funktioniert :( Kann die SD befekt sein ?! Oder kann ich auch einen Schnellen USB Stick kaufen ? habe damals aber was gelesen das es nicht so gut ist mit USB Stick !?