Beiträge von muelleimer321

    Nur so als Feedback


    Thx, aber r200 geht bei mir nicht. Bekomme immer, trotz https Anpassung in der EPGImport.py Zeile 187, einen SSL Fehler

    Zitat

    if filename.startswith('https:') or filename.startswith('http:') or filename.startswith('ftp:'):

    Auch wenn ich auf http gehe kommt selbe SSL Fehler, hm


    Bin wieder auf der alten Version (enigma2-plugin-extensions-epgimport_1.0-r36.6-all.deb)

    da gehts.

    Habe viel getestet, aber muss jetzt resignieren. Die Stelle meines Problemes habe ich aber ausgemacht.

    Es werden mir in der EPG Ansicht bzw. in der epg.db nur Inhalte ab dem 30.1 ausgewiesen, obwohl das Plugin aktuelle EPG Daten meines erachtens importiert

    ....


    Dann findet der Importer weiter später in der XML weitere EInträge des Senders und hier passiert es dann, epgdb.py ~ Zeile 196

    Es wird erstmal ein Delete auf die service_id gemacht. Heißt alles bisher importiere wird entfernt.


    usw.

    Nicht irritieren lassen, dieser Auszug stammt aus einem vorigen Lauf


    Am Ende wenn die Import Routine fertig ist und ich ziehe mir die epg.db ab und schick SQLs für goTV aus z.B

    Code
    1. select * from T_Event where service_id=3

    Ergebnis wie vermutet. Alles seit dem letzten Delete im Durchlauf ist weg und es gibt nur Einträge mit dem Timestamp ab 1548824400 was dem 30.01. 6 uhr entspricht.

    Ok bei mir sind es 14 Tage, alter EPG 0 Stunden, aber ich glaub wir haben aneinander vorbei geschrieben.

    Ich kann den alten EPG in den Einstellungen nur auf maxial 96 Stunden beim DreamOS einstellen.

    Ich wollte mit meinem Post ausdrücken, wenn ich heute den EPG-Import anstarte, dann habe ich von den Sendern einen EPG am 1.2.

    Starte ich den Importer morgen wieder an, dann habe ich auf den Sendern nur einen EPG vom 2.2.

    Die vom 1.2 sind weg. Habe das jetzt 3 Tage analysiert.

    Das spiegelt sich auch in der epg.db so ab

    Ok.

    Ich habe es mir nochmals angesehen. epg.db geleert und neu importieren lassen.

    Es werden immer nur die Daten des letzten Datums aus der Datenquelle .xml File importiert (obwohl dort für jeden Sender bis zu 14 Tage Inhalte enthalten sind. Am nächsten Tag sind wieder nur die Daten des letzten Tages enthalten.

    Es wirkt so als würde grundsätzlich immer alles zum Source Rytec XML (Prio 99) geleert werden und die neusten Daten dann importiert

    Nach vielem hin und her geteste muss ich feststellen. Die Daten werden wie schon gesagt importiert, aber sie werden nur für den 26.01.2019 (also letzter Tag vom eingestellen Zeitrange 14 Tage vom DreamOS) in der EPG-Liste ausgewiesen.

    Im Plugin ist aber nur up to 2 Days eingestellt.

    Ich habe die aktuell Version jetzt auf meinem dm920 eingespielt, dabei habe ich 2 Probleme

    Also in meinem source file gibt es keine https quellen. Wenn sich da was im EPGImporter getan hat dann müsste wohl wieder mal jemand die aktuellen sourcen ans DreamOS anpassen - solange es aber noch funktioniert habe ich wenig Lust dazu, kann aber gerne auch mal wer anderer machen

    Naja der 1. Punkt kann ja einfach durch eine Anpassung der py behoben werden.

    Das nicht anzeigen der Importierten EPG Daten ist eher mein Problem aktuell

    Ich habe die aktuell Version jetzt auf meinem dm920 eingespielt, dabei habe ich 2 Probleme


    - Source/EPG.xml kann von keiner Domain bezogen werden die das Protkoll https verwendet, da in der EPGImport.py nur http und ftp erlaubt sind

    - Importierte Events tauchen in der Favoritenliste nicht auf, epg.db File wurde aber aktualisiert. Größe stieg an und Dateidatum wurde geändert

    Erkenne aber kein Problem


    Kanalzuweisung in der channels.xml passt aber.

    Wenn man mit einem SQLLite Tool die epg.db einsieht scheinen die Einträge auch ordnungsgemäss enthalten zu sein


    Verwendet wird: Dreambox OS Version: 4.3.1r28-115-g20699-2018-10-02


    Jemand ne Idee?

    Für alle die auch mit der aktuellen enigma2-plugin-extensions-xmltvimport_2.3-r6_mipsel.deb noch folgende Probleme bekommen. Es liegt wohl an der Quelle. Bei 2 von 3 Quellen der bekomme ich massig Fehler im Log ala


    Zitat

    enigma2[173]: [EPGImport] ### importEvents exception: database disk image is malformed
    enigma2[173]: [EPGImport] ### importEvents exception: epgdb_class instance has no attribute 'source_id'


    beziehe ich die Daten von der anderen Quelle tauchen die beiden Fehler grundsätzlich im Log nicht auf


    Zitat

    epgdb_class instance has no attribute 'source_id'


    heißt aber auch soviel wie keine Daten gefunden, da die letzte Datengenerierung von Ende März ist ;-)
    [edit by Mod.] Bitte Ausgaben/Log`s, etc., der besseren Übersicht wegen, immer als Zitat/Code. Danke

    Kann es sein, dass seit dem letzten DMM Update im dbBackup Plugin der Pfad zur Definition der EPG Backup-Datei nicht mehr einstellbar ist?
    es legt jetzt meine epg Backups immer unter /etc/enigma2 ab statt wie bisher /media/hdd/backups. Ich kann auch kein anderen Pfad mehr auswählen, während beim Orginalen EPG Pfad weiterhin /media/sd wo auch die epg.db liegt auswählbar ist.


    Gemini Plugin und auch epgcachedir steht epg auf /media/sd

    das selbe auch beim speichern (nur als Feedback)


    Mit den heutigen Updates der DM7080HD crasht das Plugin beim ausführen oder Settings speichern

    Mit dem aktuellen Update der 7080HD crasht das Plugin beim laden/importieren.
    Log schreibt es leider mit 0bytes


    vom mitsniffen

    da hast du auch Recht, da ist es auch. Sorry, Plugin verwechselt :(


    [edit by mod.]
    Bitte keine Beiträge extra noch einmal zitieren wenn du direkt darauf eine Antwort gibst.
    Es macht doch eh keinen Sinn, und keiner möchte immer alles doppelt lesen.
    Danke.

    Bekomme während des Betriebs v0.5 (jede Stunde folgenden Greenscreen)