Beiträge von carbonide

    journalctl ist bei mir auch nicht farbig, wenn ich aber enigma mit "systemctl start enigma2" starte habe ich gar keinen Output.


    Müssten da die Meldungen nicht automatisch im telnet erscheinen?

    Mit der 0.58 kann ich nichts fremdes mehr im RMC EPG erkennen!


    Aber ein kleines Problem habe ich noch entdeckt: auf der Bluetooth Fernbedienung gibt es keine TV Taste mehr. Vielleicht könnte man zusätzlich die Rechts-, Links-Tasten neben der 0 auf der BT Fernbedienung benutzen (da scheint es sich um HOME und END Tasten zu handeln, so verhalten sie sich in der Kanalliste)?

    Ja, ich benutze immer REC und TEXT um sicher zu sein.


    Ausserdem ist RMC immer noch ein wilder Mix von verschiedenen EPGs. Vielleicht liegt es ja daran dass die Sendereferenz mit 1:0:1... beginnt, aber wenn ich den Sender mit 1:0:19... wähle kommt die "Tunen fehlgeschlagen" Meldung.

    Bei mir ist RMC auch noch immer ein wilder Wirrwarr von verschiedenen EPGs, aber komischerweise völlig andere Daten wie bei dir.


    Auuserdem habe ich ein neues Problem: bei einigen Sendern (z. B. ard-Alpha) wird in der Senderliste kein EPG angezeigt, obwohl Daten für mehrer Tage geladen wurden. Normalerweise wird wenn man auf einen Sender tuned danach EPG in der Kanalliste angezeigt, aber für diese Sender bleibt jetzt die Zeiel hinter dem Namen einfach leer (auch nach mehrmaligem Hin- und Herschalten).

    Ich habe bestimmt nicht an der Referenz rumgefummelt, vielleicht ist meine satellites.xml aus anderen Quelle wie deine (manchmal erneuere ich diese über ein Plugin, manchmal über eine Internet Seite).


    Und das erklärt ja auch nicht die Probleme, die ich mit anderen Sendern habe.


    PS: Entschuldigungs Modus an: Deutsch ist nicht meine Muttersprache :)

    Edit: PPS: und das war noch nicht mal ich der "es ladet" geschrieben hat 8o

    TXT und REC bevor Download, danach EPG vorhanden für alle Sender, hier einige falsch geladene:


    #SERVICE 1:0:1:BBC:4E84:55F:DDE0000:0:0:0::RMC Découverte

    #DESCRIPTION RMC Découverte


    #SERVICE 1:0:1:4465:453:1:C00000:0:0:0::kabel 1 Doku

    #DESCRIPTION kabel 1 Doku


    #SERVICE 1:0:19:1B1D:802:2:11A0000:0:0:0::BBC 1

    #DESCRIPTION BBC 1


    #SERVICE 1:0:19:5104:80F:2:11A0000:0:0:0::ITV 1

    #DESCRIPTION ITV 1


    Dies sind alles Sender die ich umbenannt habe (was man am geänderten Namen hinter :: ja erkennt), ich habe das Problem aber auch bei nicht umbenannten Sendern wie z. B.:


    #SERVICE 1:0:1:2757:7FC:2:11A0000:0:0:0: (das ist CITV)


    #SERVICE 1:0:1:191:4FB0:55F:DDE0000:0:0:0: (TF1)


    Ich habe versucht sowohl französische als auch deutsche sowie englische Sender zu finden wo dies auftritt.

    Es sind leider noch viel mehr EPGs falsch: BBC1, ITV2, Yesterday (und wahrscheinlich noch mehr).


    Ich merke das erst, wenn ich auf einen Sender tune und dann über Now/Next eine völlig andere Sendung angzeigt wird :(


    Andere, z. B. ITV1, sind aber korrekt. Ich kann keinen Zusammenhang erkennen.

    Na dann will ich euch mal nicht länger warten lassen :):


    Gute Nachricht zuerst: es wurden jetzt für alle Sender EPG Daten geladen, auch wenn ich "Alle Kanäle" auf Off habe.


    Schlechte Nachricht: die Daten für RMC Découverte sind die falschen! Dort werden wild durcheinander englische, deutsche und französische Sendungen angezeigt. Aber dies kann natürlich auch an den Sourcen liegen (siehe Bild). Ich habe dies bei keinem anderen Sender bemerkt.


    Die beiden arte Sender haben übrigens die richtigen Daten erhalten (sie heissen bei mir arte und Arte).


    Manchmal vergisst das Plugin die Einstellung:


    - ich habe z. B. TV Bild anzeigen eingestellt

    - manchmal kann ich mehrer Aufnahmen abspielen und jedesmal wird danach das TV Bild im Hintergrund wieder angezeigt wenn ich die Aufnahme verlasse

    - wird aber danach nicht das TV Bild sondern die zuletzt angeschaute Aufnahme wiedergegeben, funktionniert es bin dann nicht mehr wieder, bis ich die Movie Liste verlasse und es erneut versuche

    - manchmal muss ich die Movie Liste mehrmals verlassen damit die Einstellung "TV Bild" wieder genommen wird


    Und soeben hatte ich beim normalen TV-Schauen einen Grünen und da ich schon seit Ewigkeiten keinen mehr hatte, gehe ich davon aus, dass das Plugin in veurdach hat.


    Der Crash hat kein Log hinterlassen (war also einer der härteren).

    Vielleicht könne dir die folgenden Testergebnisse bei der Fehlersuche helfen:


    - ich habe in meiner Favourites Liste RMC DECOUVERT umbenannt als RMC Découverte stehen

    - lese ich jetzt EPG finde ich dort nichts, wenn All Channels auf nein steht

    - füge ich RMC DECOUVERT mit Originalnamen dem Favourites Bouquet hinzu und starte eine neuen Import befinden sich EPG Daten in beiden Sendern

    - lösche ich RMC DECOUVERT wird wieder nichts für RMC Découverte geladen

    - stelle ich All Channels auf ja, werden für RMC Découverte Daten geladen auch wenn RMC DECOUVERT sich nicht mehr im Favourites Bouquet befindet (aber sehr wohl in der vollständigen Satellitenliste von 5°W, also ist dies eigentlich logisch)


    Also ich kann damit leben und All Channels auf ja lassen, aber einen Bug scheint's da noch zu geben (für einige Sender).

    Hier mal ein Log mit nur den EPGLoad Meldungen. Für mich sieht's in Ordnung aus, aber es wurden wiedeurm für die meisten französischen Sender kein EPG geladen (und now/next kam tatsächlich vom Sender, da ich diesmal aufgepasst habe und nicht auf einem F-Sender stand).


    ABER: komischerweise wurden EPG Daten für TF1, TF1 Séries, C Star, LCI, L'équipe und M6 (vielleicht auch weitere, dies sind die die ich in meiner Senderliste habe). Also andere wie France 2, 3, RMC Découverte bleiben komplett leer.


    Einen Verdacht habe ich immer noch: nichts geladen wird für Sender die ich umbenannt habe, und tatsächlich habe ich die meisten dieser Sender umbenannt (so z.B. entferne ich immer HD und Groassbuchstaben; aber dies tue ich auch für deutsche und englische Sender und dort tritt dieses Problem nicht auf) und du hast ja schon in einem vorherigen Beitrag geschrieben, dass über die Sender-Referenz geladen wird.


    Aber mir ist auch aufgefallen, das wenn man einen Sendernamen ändert, dann wird er geänderte Name an die Referenz drangehängt. Aber wiederum, dies trifft auf alle Sender in meinen Bouquets zu, und nicht nur auf die französischen?!?


    Bei Bild 1 (Pick TV) ist die Referenz normal, aber bei Bild 2(ONE HD umbenannt auf One) wird der String One an die Referenz drangehängt.


    Dateien

    • log.txt

      (150,16 kB, 1 Mal heruntergeladen, zuletzt: )

    Ich habe durch Zufall noch einen Bug entdeckt: wenn ich All Channels (müsste dass nicht Bouquets heissen?, siehe Screenshot) auf "yes" stelle, dann wird alles korrekt geladen.


    Stelle ich es aber auf "no" und wähle die wichtigsten Bouquets aus, werden komischerweise nur die ersten beiden Event - und dies nur die französischen Sender ! - geladen (und diese scheinen nicht vom Satsignal zu kommen, da ich sie in der Senderliste sehe, auch schon bevor ich auf einer der Sender tune).


    Wenn ich die epg.dat lösche, werden diese Events auch nicht aus der Datenbank entfernt. Die Datenbank wird wiederum nur komplett entleert, wenn "All Channels" auf "yes" steht.


    Ich hatte einen Crash, aber das war weil ich die sources.xml gegen eine leicht veränderte austauschte aber keinen Neustart machte so dass ein "out of bounds" crash bei erneutem Aufruf von EPGLoad erfolgte.


    Ich weiss nicht ob man das dem Plugin ankreiden kann, wenn man ihm die Daten sozusagen "unter den Füssen" wegzieht :)

    0.20 funktioniert bei mir auch, aber ich hatte ja bei meiner simplen Konfiguration (nichts spezielles, kein IP, kein DVB-T/C) auch schon keine Probleme mehr mit der 0.18.


    Danke für das Tausenderzeichen, aber könnte der Punkt (oder ein Apostroph) oben als Trennzeichen benutzt werden (und nicht wie jetzt ein Punkt unten der wie ein Dezimalpunkt aussieht)?.


    Ausserdem steht bei Gelb "Downloading": da könnte man meinen, dass der Download bereits läuft. Einfach "Download" wäre meiner Meinung nach klarer.

    Mit der 0.18 konnte ich jetzt erstmals den vollen EPG für alle meine Sender laden.


    Das einzige Problem ist, dass auch wenn ich 3 Wochen im voraus eingestellt habe, tatsächlich nur etwa 1 Woche geladen wird, aber das Problem bestand auch schon in EGImport.


    Zwei kleine (minimale) Verbesserungen will ich noch vorschlagen:


    - anstatt EPG#1..#2...etc warum nicht wie beim EPGImport EPG+Name des Senderpaketes?

    - könnte man die Zahl der importierten Events als 87'432 darstellen (ist lesbarer als 87432)?


    Danke gutemine!

    Um gutemine die Zeit für eine Antwort zu ersparen (damit er sich so ganz dem Code widmen kann :) ) versuche ich mich mal an einer Antwort (hoffe ich schreib nichts falsches):


    - EPGLoad basiert nicht auf dem über Jahre gewachsenen (und verhunzten) Python-Code zur Verarbeitung der EPG-Datenquellen


    - EPGLoad benutzt Standard DreamOS Funktionen (z. B. für die Listendarstellung) damit das Plugin skinbar ist

    Mein Favourites-Bouquet besteht aus englischen, deutschen und französischen Sendern (etwa 120) und mit der 0.14 werden jetzt für einige Sender alle EPG Daten geladen, für die meisten aber nicht.


    Einige EPG-Daten sind auch durcheinander, so hat Welt z.B. französische EPG-Daten zugewiesen bekommen.


    Es ist ein wilder Mix aus allen vorhandenen Kanälen; irgendeinen Zusammenhang kann ich da nicht erkennen. EPGImport mit derselben config.xml lädt seit Monaten alles problemlos, daran kann's also nicht liegen.


    Was bedeutet eigentlich der erste Parameter (Latest EPG Update (days)? Wäre es möglich mittels der Info-Taste (wie beim EPG-Import) auch angezeigt zu bekommen, wann der letzte Import durchlief und wieviele Events geladen wurden?

    "Favorites" war aktiviert, mein Bouquet heisst aber "Favourites". Mit beiden Schreibarten aktiviert ist zwar jetzt die Zahl der Kanäle nicht mehr 0, aber mit 39 immer noch viel niedriger als die eigentliche Anzahl von Kanälen in meiner Favourites-Liste (128).


    Aber ich glaube ich weiss warum: ich habe einige der Sender umbenannt (z. B. HD im Namen weggelassen, oder Grossbuchstaben in Kleinbuchstaben umgewandelt). Kann dies der Grund sein? EPGImport hatte damit keine Probleme.

    Ich habe meine sources.xml in den Ordner /etc/epgload verschoben, Quellen im EPGLoad Plugin ausgewählt, 14 Tage im voraus gewählt (mit altem EPG von 24 Stunden) und den Import manuell angestossen: über 135'000 Events werden importiert (was gleich ist mit EPGImport, das ich übrigens deinstalliert habe) aber danach finde ich bei keinem Sender EPG-Daten (ausser die per Sat ausgestrahlt werden).


    Die alte EPG Datei habe ich mit der REC-Taste gelöscht. Die neue EPG Datei ist unter 2 MB gross, mit dem EPGImport Plugin war diese etwa 10 mal so gross.


    Ich habe im enigma2 Log nach EPGLoad Meldungen geschaut, aber nichts gefunden.